Author Topic: 405 error : Method Not Allowed  (Read 14219 times)

oxydum

  • Full Member
  • ***
  • Posts: 156
    • View Profile
405 error : Method Not Allowed
« on: November 16, 2008, 07:10:54 pm »
A little message when I put OpenGoo Fr in my web server :
http://www.oxydum.com/opengoo
  utilisateur/username : demo
  mot-de-passe/password : demo

Any idea ? Thanks.
Propulsé par OpenGoo 1.5.3 sur Xampp Windows XP SP3

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #1 on: November 17, 2008, 10:23:00 am »
I had a problem with the french translation. It worked fine if I was already logged in, but when I went to the login page I got a blank page. Apparently it had some invalid characters (I think it can be related to this: http://en.wikipedia.org/wiki/UTF-8#Byte_Order_Mark). I fixed it by copying/pasting the contents of each file into a new file.

I updated the sourceforge download. Maybe you can try if this fixes your problem: http://downloads.sourceforge.net/opengoo/fr_fr_1.0.zip

P.S.: I took the liberty to update the url to the download in one of your posts  :-[
« Last Edit: November 17, 2008, 10:28:32 am by ignacio »

oxydum

  • Full Member
  • ***
  • Posts: 156
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #2 on: November 17, 2008, 12:37:00 pm »
My localhosts were a wampserver v2 (php 5.2.6) under windows xp, and a Cohesitiveft elastic server Debian 4.0 running both under virtual machines (VMWare for OpenSuse) : there are NO problems with opengoo fr.

My webserver come with a Lamp server with both php 4 and 5, and I've activated Php5 in the .htaccess like this : AddType application/x-httpd-php5 .php
See more parameters : http://www.oxydum.com/opengoo/php.php

This error tell that's a POST method invokes extra characters like a "/" at the end of a link, or not ? In fact, I don't know...  ::)
Propulsé par OpenGoo 1.5.3 sur Xampp Windows XP SP3

vassy

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
Re: 405 error : Method Not Allowed
« Reply #3 on: November 18, 2008, 09:22:11 am »
I have the same problem but with the default english language installed, any ideas?

chris

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #4 on: November 24, 2008, 09:10:38 am »
I have the same problem too (default english language installed).

dpitard

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #5 on: November 24, 2008, 06:35:56 pm »
I have the same problem when displaying help in message box

The 405 error happened when opengoo try to post in ajax on the url http://opengoo.mydomain.com/help/index.html?active_project=0&ajax=true&current=help-panel&%20=

The thing is that apache 1.3 does not allow POST on html document...

I submitted the following bug report : http://sourceforge.net/tracker/index.php?func=detail&aid=2340134&group_id=191520&atid=937707


Arthur Mullard

  • Jr. Member
  • **
  • Posts: 73
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #6 on: December 16, 2008, 10:28:14 am »
I have the same problem too (default english language installed).

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #7 on: December 17, 2008, 09:31:29 am »
It will be fixed for next release candidate of version 1.1.

haveabyte

  • Newbie
  • *
  • Posts: 9
  • #1 in Hosted Service Management Solutions.
    • View Profile
    • HaveAByte.com - #1 in Hosted Service Management
Re: 405 error : Method Not Allowed
« Reply #8 on: December 24, 2008, 05:55:05 pm »
On IIS, I managed to fix this (partially) by changing the handler for .htm and .html to SSINC.DLL (which handles server side includes) based on the advice of other IIS admins.  This allows me to enable POST on that.

Now when I log into OpenGoo, I get only one 405 error instead of two.

The other one seems to be coming from a post to the /OpenGoo folder instead of to /OpenGoo/index.php.  index.php is set as the default document so that's kind of odd.

From the logs (some details removed):

So this gives a 405:
POST /opengoo active_project=0&ajax=true&c=dashboard&a=index&current=overview-panel 405 0 1 1802 1205 62

But this does not:
2008-12-24 20:38:20 POST /opengoo/index.php active_project=0&ajax=true&c=project&a=initial_list_projects&parent=0 200 0 0 857 1215 296

This is with the 1.1 beta and I have not tried the RC yet.  I'm about to right now...

Erik Knepfler
http://haveabyte.com
« Last Edit: December 24, 2008, 05:58:32 pm by haveabyte »

haveabyte

  • Newbie
  • *
  • Posts: 9
  • #1 in Hosted Service Management Solutions.
    • View Profile
    • HaveAByte.com - #1 in Hosted Service Management
Re: 405 error : Method Not Allowed
« Reply #9 on: December 24, 2008, 06:05:39 pm »
RC1 fixed it.  Thanks!

Erik

mbacke

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #10 on: December 30, 2008, 10:48:29 am »
It will be fixed for next release candidate of version 1.1.


I still get the error "Error 405: Method Not Allowed", when I login. I'm using OpenGoo 1.1 RC2

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #11 on: December 30, 2008, 03:29:01 pm »
Maybe you are using a cached version of your javascript? Try refreshing your browser or clear your browser's cache. Are you using Apache 1.3?

mbacke

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #12 on: December 30, 2008, 04:15:00 pm »
The cache is cleared. I'm on  Apache version 1.3.41 (Unix)

o_z

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #13 on: December 31, 2008, 06:11:25 am »
I also get this message when logging in.
OpenGoo 1.1 final (english) on Apache 1.3.41 (Unix)

Cheers,
o

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 405 error : Method Not Allowed
« Reply #14 on: January 04, 2009, 04:02:35 pm »
The problem that was corrected for this version was that OpenGoo was sending GET parameters to an HTML file (public/help/index.html). This caused the 405 error on Apache 1.3. Now this is supposed to be fixed and OpenGoo shouldn't be sending parameters to HTML files

Check in you apache log if URL requests for 'opengoo/public/help/index.html' have any parameters after the index.html. If not, there may be some other problem with Apache 1.3 that we haven't detected.

 

anything