Author Topic: [1.7 beta] email not going into workspace  (Read 6751 times)

bobena

  • Newbie
  • *
  • Posts: 15
    • View Profile
[1.7 beta] email not going into workspace
« on: May 11, 2010, 01:15:45 pm »
Perhaps I'm just missing something, but I have a problem with the cron and email. 

I have two email accounts setup, both are POP due to prior issues with IMAP.  Anyway - when we manually click "check mail" the mail is visible in the workspace.  When the cron checks the mail, we can't find it in the workspace.  It shows in the "Unread mails" section in the overview, but not in the email tab itself.

Any ideas?

cabeza

  • Administrator
  • Hero Member
  • *****
  • Posts: 1004
    • View Profile
    • Feng Office
Re: [1.7 beta] email not going into workspace
« Reply #1 on: May 12, 2010, 12:13:46 pm »
To view you inbox you should select the Workspace root, labeled "All".

Does this solve your issue?

bobena

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: [1.7 beta] email not going into workspace
« Reply #2 on: May 13, 2010, 10:23:20 am »
No - not at all.  There is no email in ALL - and that doesn't make any sense.  Wouldn't I be able to see different users emails by classifying them to a different workspace?

Anyway -that's not the point.  The point is: 

When you setup the email account there is an option for:

 "Autoclassify to Workspace" If selected, all email sent to or from this account will be automatically classified to the selected workspace.


This only works if you manually check email, not if it comes in via the cron. 

cabeza

  • Administrator
  • Hero Member
  • *****
  • Posts: 1004
    • View Profile
    • Feng Office
Re: [1.7 beta] email not going into workspace
« Reply #3 on: May 13, 2010, 11:41:17 am »
We'll look at it.

bobena

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: [1.7 beta] email not going into workspace
« Reply #4 on: May 13, 2010, 12:19:11 pm »
Thank you :)

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: [1.7 beta] email not going into workspace
« Reply #5 on: May 13, 2010, 02:01:56 pm »
When you see the email in the overview widget, if you click on the email, can you see its content? does the properties box, at the right, show any workspace?

bobena

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: [1.7 beta] email not going into workspace
« Reply #6 on: May 13, 2010, 02:14:53 pm »
No, if you click on one in the overview that came in through the cron we cannot see content, nor is there a workspace highlighted.  It's also not showing in the og_workspace_objects table like the ones that come in when we click "Check mail"

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: [1.7 beta] email not going into workspace
« Reply #7 on: May 13, 2010, 04:31:36 pm »
Which version of the application are you using?

bobena

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: [1.7 beta] email not going into workspace
« Reply #8 on: May 13, 2010, 05:29:10 pm »
1.7 beta

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: [1.7 beta] email not going into workspace
« Reply #9 on: May 13, 2010, 06:35:55 pm »
Does the folders "upload" and "tmp" have write permissions for the user that runs the cron ?
These folders must be writtable for this user in order to save the email content.

bobena

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: [1.7 beta] email not going into workspace
« Reply #10 on: May 14, 2010, 02:30:23 pm »
Yes, they both have write permissions set for the cron user, but it's still not working

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: [1.7 beta] email not going into workspace
« Reply #11 on: May 14, 2010, 02:58:10 pm »
can you look at  the cron.log and cache/log.php files to look for some error message?
if you want you can send me these files and i can see if there is something legged there.

bobena

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: [1.7 beta] email not going into workspace
« Reply #12 on: May 19, 2010, 01:54:06 pm »
It seems that application/layout/websites.php is trying to call version.php, which doesn't exist... I just downloaded a fresh install to be sure I didn't do anything, and the websites.php file shows the same as mine, so I know it's not me.  There is no version.php file in that directory - do you know where it is?

websites.php starting on line 14:
Code: [Select]
$version = include "version.php";
if (defined('COMPRESSED_CSS') && COMPRESSED_CSS) {
echo stylesheet_tag("ogmin.css");
} else {
echo stylesheet_tag('website.css');
}

cache/log.php

Code: [Select]
ERROR: Error: include(version.php) [<a href='function.include'>function.include</a>]:
failed to open stream: No such file or directory in
'***removed for security***/application/layouts/website.php'
on line 14 (error code: 2)

cabeza

  • Administrator
  • Hero Member
  • *****
  • Posts: 1004
    • View Profile
    • Feng Office
Re: [1.7 beta] email not going into workspace
« Reply #13 on: June 17, 2010, 02:33:56 pm »
version.php is on the root of your feng office installation

 

anything
anything