Author Topic: Email mit state=4 werden nicht angezeigt  (Read 2436 times)

deepmessage

  • Newbie
  • *
  • Posts: 5
    • View Profile
Email mit state=4 werden nicht angezeigt
« on: December 26, 2009, 05:09:05 am »
Hallo zusammen,

ich habe gerade einige Emailtests durchgeführt. Unser Server nutzt greylisting zur SPAM-Reduktion, d. h. jede ankommende Email (welche noch nicht in der whitelist steht) wird erstmal abgeblockt mit der Bitte "schick's mir nochmal". Jeder Spam-Versender sollte diese Antworten ignorieren und valide Email-Server verschicken dann die Emails noch einmal.

Und hier ist das Problem: Wird diese Email nochmal versendet, so taucht sie in der feng-Datenbank mit dem state=4 auf und wird in der Email-Übersicht nicht angezeigt. Lediglich über die Suche kann man auf die Email zugreifen.

Hat das Problem sonst noch jemand? Weiß jemand einen Workaround, die Sache in den Griff zu bekommen?

Klar - eine kleine Anpassung im Cron, welche den Status von 4 auf 0 ("nothing" lt. Kommentar) setzt, könnte das Problem lösen, aber sonderlich elegant ist das ja nicht....

Edit: Hab nochmal im Code geschaut - ein state von 4 bedeutet offenbar "Spam". Könnte jetzt Zufall sein, ich teste nochmal...


Gruß
Alex
« Last Edit: December 26, 2009, 05:19:32 am by deepmessage »

werner.wuerfel

  • Sr. Member
  • ****
  • Posts: 319
    • View Profile
Re: Email mit state=4 werden nicht angezeigt
« Reply #1 on: December 26, 2009, 05:28:49 am »
Hallo,

ich bin der Meinung Feng Office verhält sich in dem Fall richtig. Das Verfahren Greylist ist eigentlich nicht RFC 2821 konform. Damit es funktioniert erzeugt der annehmende Mailserver einen temp. Fehler 4xy, den der zusendende Mailserver protokolliert und dann die Mail nochmals sendet.

Dann wird sie angenommen mit den Status 4 - also absolut richtig. Da der eigene Mailserver das so provoziert hat.

Gruß
Werner Wuerfel

deepmessage

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Email mit state=4 werden nicht angezeigt
« Reply #2 on: December 26, 2009, 08:49:58 am »
Hallo Werner,

danke für Deine schnelle Antwort.

Ich habe das nochmal durchgespielt - die Emailgeschichte ist korrekt, es war Zufall, dass gerade die erste Mail (zurecht) als SPAM erkannt wurde.

Gruß
Alex

 

anything