Author Topic: [SOLVED W/ CODE EDIT] 1.6Final Email Module Unable to Classify emails  (Read 3664 times)

a2opinion

  • Full Member
  • ***
  • Posts: 177
  • Christian
    • View Profile
    • A Second Opinion
Trying to Classify an email now gives me the error "No Attachments found for Email"

I am unable to find anyway to "Assign a workspace to a mail account to automatically classify email to that workspace" either...

adding an inline image to the email via upload, clicking on "Add to server" gives a 505 server error.
« Last Edit: December 14, 2009, 04:29:06 pm by a2opinion »

iTristan

  • Newbie
  • *
  • Posts: 10
    • View Profile
    • Email
Re: 1.6Final Email Module Unable to Classify emails
« Reply #1 on: December 10, 2009, 07:15:18 pm »
Exactly the same for me. Have tried some older fixes to no avail. (tmp permissions)

Looking for other insight as well.

iTristan

  • Newbie
  • *
  • Posts: 10
    • View Profile
    • Email
Re: 1.6Final Email Module Unable to Classify emails
« Reply #2 on: December 10, 2009, 07:28:07 pm »
UPDATE : tried with message containing attachments and that worked fine.

So, if the error is to be believed, then the classify function is missing out on sniffing an attachment's existence properly.

seraphim

  • Freshman
  • *
  • Posts: 15
    • View Profile
Re: 1.6Final Email Module Unable to Classify emails
« Reply #3 on: December 11, 2009, 11:50:23 am »
I have this problem to.

No problem on mails which have attachments, but if not, it throws the error message "No attachments found for email".

Anyway, this error occurs only if I use the classify function. Otherwise, if I drag the mail onto the wanted workspace, it works successfully.

gvagenas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: 1.6Final Email Module Unable to Classify emails
« Reply #4 on: December 11, 2009, 12:10:26 pm »
I confirm i have the same problem with email classification


betty111111

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
    • Email
Re: 1.6Final Email Module Unable to Classify emails
« Reply #5 on: December 11, 2009, 03:26:43 pm »
Same problem here too.

I am able to drag emails onto workspaces to classify them still.

Jödel

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: 1.6Final Email Module Unable to Classify emails
« Reply #6 on: December 11, 2009, 05:04:35 pm »
Same Problem here too.

Classification only possible by using drag and drop
Using OpenGoo 1.6

iTristan

  • Newbie
  • *
  • Posts: 10
    • View Profile
    • Email
Re: 1.6Final Email Module Unable to Classify emails
« Reply #7 on: December 12, 2009, 02:09:10 pm »
yes confirmed, hadn't tried drag and drop – this does work. But for me, this is rather a pain compared to the classify button.

At least it does sort of work though.

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 1.6Final Email Module Unable to Classify emails
« Reply #8 on: December 14, 2009, 12:14:40 pm »
Can you try editing file 'application/controllers/MailController.class.php' and change line 935 from:

Code: [Select]
//Classify attachments
$this->classifyFile($classification_data, $conv_email, $parsedEmail, $validWS, true, $csv);

to:

Code: [Select]
if ($conv_email->getHasAttachments()) {
//Classify attachments
$this->classifyFile($classification_data, $conv_email, $parsedEmail, $validWS, true, $csv);
}

a2opinion

  • Full Member
  • ***
  • Posts: 177
  • Christian
    • View Profile
    • A Second Opinion
Re: 1.6Final Email Module Unable to Classify emails
« Reply #9 on: December 14, 2009, 04:25:24 pm »
this fixed the problem.

Though this morning I lost the ability to read emails for some reason...

Didn't make any changes at all.. but now opening an email gives me this error where the body of the email should be:
Quote
Error

We are sorry, but OpenGoo is not currently able to execute your request. An Error Report has been sent to the administrator.

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: [SOLVED W/ CODE EDIT] 1.6Final Email Module Unable to Classify emails
« Reply #10 on: December 14, 2009, 04:40:33 pm »
Check if you have the "tmp" folder. Today I had that error and it was because my "tmp" folder was gone. It is a bug when clearing old files from the tmp folder. It will be fixed for next release.

a2opinion

  • Full Member
  • ***
  • Posts: 177
  • Christian
    • View Profile
    • A Second Opinion
Re: [SOLVED W/ CODE EDIT] 1.6Final Email Module Unable to Classify emails
« Reply #11 on: December 14, 2009, 04:49:19 pm »
where should the tmp folder be located?  in the root?

nevermind.. found it on my local copy and put the directory.  Now the issue is fixed.

(the answer to my question was 'yes')

 

anything