Author Topic: Archived Objects  (Read 3231 times)

dkouis

  • Newbie
  • *
  • Posts: 3
    • View Profile
    • Email
Archived Objects
« on: December 01, 2009, 08:36:44 am »
Hi to all,
Congratulations for the effort and for providing such a nice tool.
We currenty using 1.6RC version !
We have noticed that when you archive an object that doesnt appear at the Archived Objects folder.
When you search with a keyword for this object, you find it and you can unarchive it !
No error log appears (we set the debug to true). The only strange we noticed is that in history window of the object we get the following error (sorry for the greek names ..) :
Today, 13:29:35    Δημήτρης Κουής    Missing lang: log archive projecttasks
Today, 13:27:31    Δημήτρης Κουής   Missing lang: log unarchive projecttasks
Today, 13:20:38    Δημήτρης Κουής   Missing lang: log archive projecttasks
Today, 13:20:28    Δημήτρης Κουής   Missing lang: log unarchive projecttasks
Today, 13:10:09    Δημήτρης Κουής   Missing lang: log archive projecttasks

Any ideas?

Thanks in advance




ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Archived Objects
« Reply #1 on: December 01, 2009, 02:12:58 pm »
Hi,

Notice that when viewing Archived objects the regular workspace and tag filters also apply. Is the object shown when viewing "All" workspaces and "All" tags?

dkouis

  • Newbie
  • *
  • Posts: 3
    • View Profile
    • Email
Re: Archived Objects
« Reply #2 on: December 02, 2009, 03:42:17 am »
I tried what you suggested and nothing. But this problem occured when archiving task objects. When we tried documents it worked ok (Althought the text box at the top showed Missing lang: Succesful archive object)
The same probles as in the case of task object applies with calendar entries.
I hope this helps you.


ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Archived Objects
« Reply #3 on: December 02, 2009, 09:29:26 am »
It seems to work OK for me in 1.6 RC. You can try it at demo.opengoo.org (1.6 beta2). There must be something else about these tasks and events that are interfering. Can you think of anything special about those tasks and events?

dkouis

  • Newbie
  • *
  • Posts: 3
    • View Profile
    • Email
Re: Archived Objects
« Reply #4 on: December 07, 2009, 09:51:10 am »
I think there is a problem with the Greek Characters ... I will investigate more

gvagenas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Archived Objects
« Reply #5 on: December 10, 2009, 08:31:51 am »
I also think that this is a bug.

For me, when i archive a task, sometimes i can see it on the "Archived Object" and sometimes no.
Also, if i choose un-Archive sometimes its working and sometimes not.

Nothing to do with Greek characters.

My installation is 1.5.3 upgrade to 1.6.0
« Last Edit: December 10, 2009, 09:24:37 am by gvagenas »

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Archived Objects
« Reply #6 on: December 10, 2009, 04:52:37 pm »
How do you archive tasks? By using the toolbar button in the task listing or by entering the task's view and clicking on the "Acrhive" action?

gvagenas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Archived Objects
« Reply #7 on: December 10, 2009, 06:03:09 pm »
I am using the toolbar button to archive the tasks

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Archived Objects
« Reply #8 on: December 14, 2009, 11:07:58 am »
Could it be that completed tasks are not shown while pending tasks are?

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Archived Objects
« Reply #9 on: December 14, 2009, 11:12:19 am »
Try changing line 1057 of 'application/controllers/ObjectController.class.php' from:

Code: [Select]
$completed = $trashed ? '': 'AND `completed_on` = ' . DB::escape(EMPTY_DATETIME);
to:

Code: [Select]
$completed = ($trashed || $archived) ? '': 'AND `completed_on` = ' . DB::escape(EMPTY_DATETIME);

gvagenas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Archived Objects
« Reply #10 on: December 16, 2009, 08:39:13 am »
Ignacio,

Yes that  worked... The archived tasks were completed and by changing the code i can see them in the archived list.

Thanks

mailnet_uk

  • Newbie
  • *
  • Posts: 29
    • View Profile
    • Email
Re: Archived Objects
« Reply #11 on: December 16, 2009, 04:40:00 pm »
On a similar subject, I archived a couple of document objects in the latest 1.6 stable version and got the error: "Missing lang: success archive files" although the files did archive successfully.

 

anything
anything