Author Topic: Error: The MTA doesn't support any of Swift's loaded authentication mechanisms  (Read 4987 times)

cdtracks

  • Newbie
  • *
  • Posts: 2
    • View Profile
    • Email
Al enviar un mail de prueba utilizando SMTP.

Me tira el siguiente error:

Error: The MTA doesn't support any of Swift's loaded authentication mechanisms

--

When sending a test email using SMTP I get:

Error: The MTA doesn't support any of Swift's loaded authentication mechanisms
« Last Edit: November 23, 2009, 01:17:59 pm by ignacio »

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Prueba agregar esto en 'config/config.php':

Code: [Select]
define('SWIFT_AUTHENTICATOR', 'PLAIN');

--

Try adding this to 'config/config.php':

Code: [Select]
define('SWIFT_AUTHENTICATOR', 'PLAIN');

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
If I'm not mistaken, adding this constant will force all email accounts to use PLAIN authentication. I guess this is not desirable, so I'll add a new constant for next version called DEFAULT_SWIFT_AUTHENTICATOR, that will only be used when no other authentication mechanism works.

yaronelh

  • Newbie
  • *
  • Posts: 9
    • View Profile
I had the same issue, just came in to tell you how I solved it.
and maybe help others along the way

my host is godaddy,

end and godaddy if you want to send mail in PHP, which is what Swift does
you have to use a different SMTP mail server

http://help.godaddy.com/article/951

so the SMTP server needs to be configured like this to work

SMTP Server ---> relay-hosting.secureserver.net
SMTP Server Port -----> 25
SMTP Server Authentication ---- >  no authentication
Secure connection ------>  no

then sending mail with opengoo works , in godaddy shared hosting plans

tek12

  • Guest
Hi, also with the same problem... however my server's are not on godaddy - they are mine. I also had these lines in my cache/log.php
Code: [Select]
#1 ERROR: Error: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]:
SSL operation failed with code 1. OpenSSL Error messages:
   error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number in
   '/opt/www/feng/library/swift/lib/Swift/Connection/SMTP.php' on line 149 (error code: 2)
#2 ERROR: Error: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]:
   Failed to enable crypto in '/opt/www/feng/library/swift/lib/Swift/Connection/SMTP.php' on line 149 (error code: 2)
#3 ERROR: Error: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to
    tls://mail.domain.com:25 (Unknown error) in '/opt/www/feng/library/swift/lib/Swift/Connection/SMTP.php' on line 149 (error code: 2)
#4 DEBUG: Connection to the given MTA failed.

It almost made me think I was missing a needed PHP library (failed to enable crypto). However I couldn't find anything...

I was able to send emails using No Authentication and the addition of :
Code: [Select]
define('SWIFT_AUTHENTICATOR', 'PLAIN');to config/config.php

This is, obviously, less than ideal. As an additional work around I've had to disable TLS as a requirement on my mail server.

Is there anything else I can do to re-enable security?

Thanks - loving Opengoo/Feng Office.

tek12

  • Guest
I'm checking the new version of Feng (1.6.2) and it looks like this is still an issue?

Is there anything we can do to workaround this, so we can send email via ssl/tls?

Optionally, it would be great if there was an option to use localhost as the SMTP server. That would also bypass the need for security, I've tried sending email from localhost and 127.0.0.1  with no security, however all I get is:

Cannot read property 'nodeName' of undefined

Thanks
Daniel

 

anything