Author Topic: Cannot get emails autochecked  (Read 2940 times)

hamen

  • Newbie
  • *
  • Posts: 12
    • View Profile
Cannot get emails autochecked
« on: November 07, 2009, 11:01:46 am »
Hi, I'm using 1.6b2.
My crontab setup is:
Code: [Select]
*/1 * * * * /usr/bin/wget -q http://127.0.0.1/opengoo/cron.php
/var/log/syslog says:
Code: [Select]
/USR/SBIN/CRON[26383]: (root) CMD (/usr/bin/wget -q http://127.0.0.1/opengoo/cron.php)
My emails never update. POP3 link woks. If I manually click "Check mails", Opengoo fetches mail and put them in Inbox.
I activated debug in config.php. In /var/www/opengoo/cache/log.php I have:
Code: [Select]
Session "default" started at 2009-11-07T13:48:33+0000
#1 ERROR: Error: Undefined variable: option in '/var/www/opengoo/application/functions.php' on line 454 (error code: 8)
Time since start: 0.163540840149 seconds

Any idea about automatic check problem?
Thanks,
hamen

hieutran

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Cannot get emails autochecked
« Reply #1 on: November 13, 2009, 12:33:20 pm »
me too

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Cannot get emails autochecked
« Reply #2 on: November 16, 2009, 05:26:25 pm »
What do you get when you run this command in the command line:

Code: [Select]
wget -q -O - http://127.0.0.1/opengoo/cron.php
You can also try changing the command to:

Code: [Select]
php /path/to/opengoo/cron.php

hamen

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Cannot get emails autochecked
« Reply #3 on: November 21, 2009, 09:20:23 am »
Code: [Select]
wget -q -O - http://127.0.0.1/opengoo/cron.php

I got nothing.

Code: [Select]
php /path/to/opengoo/cron.php

I got nothing.

Code: [Select]
$ tail -f /var/log/syslog
Nov 21 13:16:01 seth /USR/SBIN/CRON[21926]: (root) CMD (/usr/bin/php5 /var/www/opengoo/cron.php)
Any idea?

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Cannot get emails autochecked
« Reply #4 on: November 24, 2009, 11:03:34 am »
Check in  "Administration" / "Cron Events", if email checking is enabled, has an appropriate value for "delay" and has an empry date or a date in the past.

hamen

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Cannot get emails autochecked
« Reply #5 on: November 24, 2009, 06:02:15 pm »
Everything looks fine :-/ but it still does not work.
hamen

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Cannot get emails autochecked
« Reply #6 on: December 01, 2009, 01:33:40 pm »
Try disabling all crons you may have setup, change the date of the "Check email" cron event to a date in the past, access in a web browser the url to the cron.php file (http://<your installation>/cron.php). Check if anything is printed (it should at least print: "Checking email..." and "0 emails fecthed".

hamen

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Cannot get emails autochecked
« Reply #7 on: December 02, 2009, 06:01:09 am »
Code: [Select]
2009-12-02 08:59:01 - Checking email...
2009-12-02 08:59:05 - 0 emails fetched.

has been printed.
What now? :-/
hamen

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Cannot get emails autochecked
« Reply #8 on: December 02, 2009, 09:21:05 am »
Then it must be working! Are you sure manual checking is working but automatic checking is not? If you now check emails manually, do you get new emails?

hamen

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Cannot get emails autochecked
« Reply #9 on: December 02, 2009, 11:18:24 am »
For instance, this notification has been sent at 13.21. I clicked "Check mail" right now and opengoo showed me this new mail.
I noticed if I change workspaces, moving around in tasks, notes... then calendar... when I come back to mail it shows new unread mail.
I'm wondering if it actually fetches them, but simply does not show them.
Anyway I'm getting confortable at clicking "Check mail" button. I pressed it so many time, I do it "automatically" now... -_-'
hamen

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Cannot get emails autochecked
« Reply #10 on: December 02, 2009, 11:27:18 am »
Now I understand the problem. You expect the email view to refresh automatically but it doesn't. When you move around your are refreshing the email view, and so new email fetched by cron appears.

You may say that if email doesn't appear automatically then there's no need for using the cron, but it will save you time because fetching email from the server is much slower than just refreshing the email view. And we are planning to support automatic refresh of all views in OpenGoo soon.

hamen

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Cannot get emails autochecked
« Reply #11 on: December 02, 2009, 12:32:33 pm »
Oh OK  ;)
It was just a misunderstanding :)
I thought Email feature was like Gmail, i.e. UI pushes mails to you after server pulled them from pop3.
No bad. I'll keep on clicking "Check mail", waiting for new goodies :)
Thanks,
hamen

 

anything
anything