Author Topic: [1.6 beta] Upgrade from 1.5.3 failed  (Read 3798 times)

werner.wuerfel

  • Sr. Member
  • ****
  • Posts: 319
    • View Profile
[1.6 beta] Upgrade from 1.5.3 failed
« on: October 26, 2009, 09:10:04 am »
There is a bug by the upgrade from 1.5.3 to 1.6 beta. After no replay from the developer team here: http://forums.opengoo.org/index.php?topic=3044.0 I post the bug here again:

First I installed 1.5.3 and import my database backup. Then I installed 1.6 beta and made the upgrade.

I do the upgrade manually and I got the following message by the upgrade:

Config file found and loaded. File '/config/config.php' exists and is writable Folder '/config' exists and is writable Folder '/cache' exists and is writable Folder '/tmp' exists and is writable Folder '/upload' exists and is writable Extension 'mysql' is loaded Extension 'gd' is loaded Extension 'simplexml' is loaded Upgrade script has connected to the database. Test query has been executed. Its safe to proceed with database migration. Database schema transformations executed (total queries: 30)

exception 'FileNotInRepositoryError' with message 'File '7db4b721fff9bfb26e055b846afb31e0f03f7622.png' can not be found in the repository' in C:\xampp\htdocs\opentest\library\filerepository\backend\FileRepository_Backend_FileSystem.class.php:170
Stack trace:
#0 C:\xampp\htdocs\opentest\library\filerepository\FileRepository.class.php(95): FileRepository_Backend_FileSystem->setFileAttribute('7db4b721fff9bfb...', 'public', true)
#1 C:\xampp\htdocs\opentest\public\upgrade\scripts\ChivitoUpgradeScript.class.php(158): FileRepository::setFileAttribute('7db4b721fff9bfb...', 'public', true)
#2 C:\xampp\htdocs\opentest\public\upgrade\library\classes\ScriptUpgrader.class.php(199): ChivitoUpgradeScript->execute()
#3 C:\xampp\htdocs\opentest\public\upgrade\index.php(25): ScriptUpgrader->upgrade('1.5.3', '1.6-beta')
#4 {main}

The upgrade process is not successful. The file  installed_version is not changed to 1.6-beta.
When you looked in to OpenGoo 1.6 beta you have only the Overview.

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: [1.6 beta] Upgrade from 1.5.3 failed
« Reply #1 on: October 26, 2009, 09:47:45 am »
Hi Werner,

after restoring the backup, you should also restore the 'upload' folder, then run the upgrade.

That 'FileNotInRepositoryError' is thrown when a file exists in the database but it doesn't exists in the 'upload' folder.

regards

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: [1.6 beta] Upgrade from 1.5.3 failed
« Reply #2 on: October 26, 2009, 09:57:47 am »
We'll correct the error anyway because it should still upgrade even if you didn't copy the upload folder.

Thanks.

werner.wuerfel

  • Sr. Member
  • ****
  • Posts: 319
    • View Profile
Re: [1.6 beta] Upgrade from 1.5.3 failed
« Reply #3 on: October 26, 2009, 02:41:21 pm »
Hi Guys,

thanks for replay. In the first time I used an exiting 1.5.3 installation with uploaded data, users and so on.
This installation works under 1.5.3 fine without any error. I used this installation all so for upgrades from 1.4 to 1.5.

With this installation I tried the upgrade from 1.5.3 to 1.6 beta with my error.

How can I find out the missing file and can delete this entry in the database or restore the file in the upload folder?

Werner Wuerfel

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: [1.6 beta] Upgrade from 1.5.3 failed
« Reply #4 on: October 26, 2009, 03:08:15 pm »
That image seems to be a company logo, contact photo or user's avatar.

Run these sql queries in your DB, one of these will return the registry that contains that picture.
Code: [Select]
SELECT * FROM `og_users` WHERE `avatar_file` = '7db4b721fff9bfb26e055b846afb31e0f03f7622.png'
Code: [Select]
SELECT * FROM `og_contacts` WHERE `picture_file` = '7db4b721fff9bfb26e055b846afb31e0f03f7622.png'
Code: [Select]
SELECT * FROM `og_companies` WHERE `logo_file` = '7db4b721fff9bfb26e055b846afb31e0f03f7622.png'

After you found the registry you must set the value of the image id column to ''
(image id column is 'avatar_file' for users table, 'picture_file' for contacts table, 'logo_file' for companies table).

After doing this, the upgrade script will not try to find that file.

regards

werner.wuerfel

  • Sr. Member
  • ****
  • Posts: 319
    • View Profile
Re: [1.6 beta] Upgrade from 1.5.3 failed
« Reply #5 on: October 26, 2009, 05:35:54 pm »
Hi Guys,

thanks for your help. I checked the DB with your queries. After I found the registry and clear the value of the image id I tried the upgrade again.
Then I have the same error during the upgrade with another picture name.

So I reinstalled version 1.5.3 include backup. Then I checked all user, contacts and company pictures in version 1.5.3. I noted every entry with a picture and checked it with the queries.

Finally I have to clear about over 15 entries.

Then I can do the upgrade successful. So now I can test version 1.6 beta with all informations and data's.

By this way I think we need a tool or procedure to check the DB data and upload files are to bee consistent, before I do any update.

In my local installation under XAMPP I have only some users, informations, data's and uploads. So I can check the data with your queries. But in our productive used installation on our web-server we have a lot of more data's. There must work every upgrade very well...

Werner Wuerfel

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: [1.6 beta] Upgrade from 1.5.3 failed
« Reply #6 on: October 27, 2009, 10:01:43 am »
Where you able to see avatars before deleting them from the database? Or in other words, can you see avatars for those users in your original installation? If so, can you copy the URL to the avatar file and paste it here (right click on the image and choose "Copy image URL" or "Copy Image Location" or "Properties" and copy the URL). Remove if you want the domain part of the URL.

Thanks.

werner.wuerfel

  • Sr. Member
  • ****
  • Posts: 319
    • View Profile
Re: [1.6 beta] Upgrade from 1.5.3 failed
« Reply #7 on: October 27, 2009, 10:48:54 am »
Hi Ignacio,

exactly this I checked manually in the hole installation. I have a look to every user, contacts and company information.

If I see there no avatar, I noted this and cleared in the next step these entries in the database.

Werner Wuerfel

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: [1.6 beta] Upgrade from 1.5.3 failed
« Reply #8 on: October 27, 2009, 10:59:56 am »
When upgrading from version 1.4 to 1.5 the avatars should have been moved from 'public/files' to 'upload'. Do you remember having any errors when upgrading from 1.4 to 1.5?

werner.wuerfel

  • Sr. Member
  • ****
  • Posts: 319
    • View Profile
Re: [1.6 beta] Upgrade from 1.5.3 failed
« Reply #9 on: October 27, 2009, 11:28:32 am »
No we have no errors by upgrade all our installations from 1.4 to 1.5.

Some informations to our infrastructure: I have local on my computer under XAMPP three installations of OpenGoo (productive, training, test).
Also we have three installations of OpenGoo (productive, training, test) on our web-server.

So in the first step when a new version OpenGoo is come I installed this version local on my computer to the test installation.
Then I used this installation for test the upgrade, complete the DE translation and so on.

When the RC release is come then I upgrade the test installation on our web-server too.

With the final release all other installation will be upgrade. At last the productive installation on our web-server.

Werner Wuerfel
« Last Edit: October 27, 2009, 11:38:47 am by werner.wuerfel »

fcoauga

  • Jr. Member
  • **
  • Posts: 51
  • www.augadaterra.org
    • View Profile
    • Auga da Terra
Re: [1.6 beta] Upgrade from 1.5.3 failed
« Reply #10 on: October 27, 2009, 06:40:16 pm »
Perhaps the file missed is not the problem. My explain:

I had similar error in 2 diferent installations. Twice was a bakup of the 1.5.3 installation, running ok, and upgrading to 1.6beta.

The result was similar message to you, and the screen attached sshot-103. When click on 'account' a new window opens on my navigator; can see it in attached file sshot-104 (in this case, the style sheet was missing too...)

Tested with Mozilla, Opera and Chrome.

Solved cleaning private data on Mozilla (included cookies, I lost my delicious data and others...). Mozilla starts Opengoo 1.6 correctly now.  Opera and Chrome works too!!

Could be similar to this old post

And now, the file missing is not problem??? Nothing change about this, and 1.6beta are works fine...

Two ideas:
1.- the installation fails, but perhaps not for this error
2.- can be a bug the lost of a file?

Regards

-----
Testing Opengoo:
 external server with PHP 5.1.6 & MySQL 5.0.45
 locally server with PHP 5.2.0 & MySQL 5.0.27
Viewed with Mozilla 3.0.1 & Opera 9.60

 

anything