Author Topic: 1.5.3 - Problem with search function in OpenGoo  (Read 3375 times)

werner.wuerfel

  • Sr. Member
  • ****
  • Posts: 319
    • View Profile
1.5.3 - Problem with search function in OpenGoo
« on: September 13, 2009, 12:30:56 pm »
Hi Guy's

in the Forum are a lot off topic's to problems with the search function in OpenGoo. You know it... ;)

So we here also that is planed for version 1.6 to change the search function.

You please tell us, what the search function today can find an what not. With fields are using by the search function?

Example: In our OpenGoo instance all user's belong too one company "St. Pauli-Gemeinde" and all have a contact. When I now search after Pauli-Gemeinde so I will found only 10 contacts - not more. But we have a lot more users and contacts.

Another user off the DE-Communtiy has the same problem: http://forums.opengoo.org/index.php?topic=2700.0

Currently we receive search results and do not know whether they are complete or not.

So we can't  use the search feature today in OpenGoo.

Can we disable the Search function in version 1.5.3 as workaround until we have version 1.6 with a new search engine?

Waiting for a hopeful response...
Werner Wuerfel 

refly

  • Newbie
  • *
  • Posts: 5
    • View Profile
    • Email
Re: 1.5.3 - Problem with search function in OpenGoo
« Reply #1 on: September 14, 2009, 05:00:34 am »
I don't know whether OG will improve the search function in 1.6,
but if you want to disable the search function on the upper right,
you can edit this file:

/application/layouts/website.php

in line 85 you can find these code:

Code: [Select]
<?php
$search_field_default_value lang('search') . '...';
$search_field_attrs = array(
'onfocus' => 'if (value == \'' $search_field_default_value '\') value = \'\'',
'onblur' => 'if (value == \'\') value = \'' $search_field_default_value '\''); ?>

<?php echo input_field('search_for'$search_field_default_value$search_field_attrs?>
</td><td id="searchboxSearch">
<button type="submit"><?php echo lang('search button caption'?></button>

simply remove them or add <!-- and --> to them could disable the search form.

bateman10

  • Freshman
  • *
  • Posts: 10
    • View Profile
Re: 1.5.3 - Problem with search function in OpenGoo
« Reply #2 on: September 22, 2009, 06:21:35 am »
Thanks Werner for your contribution.
It's a problem, that the search doesn't work properly. Because we need to use the search function all over the place. That means, we add an additional field to companies. Or we just search for websites or part of the websites. And it doesn't work. We can't find the companies that for e.g. have "mobile" in their website url. This is a crucial issue for us..

Does anyone know, how to get better search results or have anyone an idea, when this issue will be fixed?

Karlos

  • Newbie
  • *
  • Posts: 45
    • View Profile
Re: 1.5.3 - Problem with search function in OpenGoo
« Reply #3 on: October 07, 2009, 06:48:10 am »
Hello ,
 this is a very important question... anybody ??

Pet

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 638
  • Always mining for solutions!
    • View Profile
    • The Bet!
Re: 1.5.3 - Problem with search function in OpenGoo
« Reply #4 on: October 10, 2009, 08:45:39 pm »
The answer is in a number of other similar threads, try a forum search.
Support OpenGoo - Sponsor a Feature! | Follow me on Twitter | OG Support Chat | Did you turn debugging on?

Karlos

  • Newbie
  • *
  • Posts: 45
    • View Profile
Re: 1.5.3 - Problem with search function in OpenGoo
« Reply #5 on: October 13, 2009, 07:15:48 am »
Hello Pet , I try forum search about "custom properties searcheable" but no solution found. Have you any information about?

Pet

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 638
  • Always mining for solutions!
    • View Profile
    • The Bet!
Re: 1.5.3 - Problem with search function in OpenGoo
« Reply #6 on: October 13, 2009, 02:48:21 pm »
the search function isn't working properly.

Support OpenGoo - Sponsor a Feature! | Follow me on Twitter | OG Support Chat | Did you turn debugging on?

werner.wuerfel

  • Sr. Member
  • ****
  • Posts: 319
    • View Profile
Re: 1.5.3 - Problem with search function in OpenGoo
« Reply #7 on: October 28, 2009, 02:52:32 pm »
Hi Guy's,

is there a time line for the new search engine. In version 1.6 beta I see no new search engine.

A successful search in OpenGoo is an very important think for all users.

Werner Wuerfel

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 1.5.3 - Problem with search function in OpenGoo
« Reply #8 on: October 29, 2009, 01:32:10 pm »
We may add a config option for using another type of search for next release, although it will have bad performance.

a2opinion

  • Full Member
  • ***
  • Posts: 177
  • Christian
    • View Profile
    • A Second Opinion
Re: 1.5.3 - Problem with search function in OpenGoo
« Reply #9 on: October 30, 2009, 12:51:00 pm »
I would be happy if the search function could also find tags...

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 1.5.3 - Problem with search function in OpenGoo
« Reply #10 on: November 02, 2009, 11:37:48 am »
It didn't find objects by a tag because of a bug that was fixed for next release. So it will search by tags.

 

anything