Author Topic: 1.5 Upload not working "Filename is required"  (Read 3364 times)

flo2

  • Newbie
  • *
  • Posts: 14
    • View Profile
    • Email
1.5 Upload not working "Filename is required"
« on: August 01, 2009, 11:22:31 am »
When I try to upload a file to documents, I get the error:

Code: [Select]
Error: Failed to save object because some of its properties are not valid:
- Filename is required

log.php shows no errors (debug turned on).

Browser is Firefox 3.5.1, Server Apache 2.2.3, PHP 5.2.0, MySQL 5.0.32

jlbenc

  • Newbie
  • *
  • Posts: 1
    • View Profile
    • Email
Re: 1.5 Upload not working "Filename is required"
« Reply #1 on: August 01, 2009, 11:28:27 pm »
Hello.

I just upgraded an hour ago (from 1.4.2) and I'm able to upload a file without a problem. I tried it in my user's _personal WS.

Mi config is: PHP Version 5.2.9, FreeBSD 6.2, Apache/2.2.10, Firefox/3.5.1

--Jose Bencosme

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 1.5 Upload not working "Filename is required"
« Reply #2 on: August 03, 2009, 11:36:48 am »
Hi flo2,

It should be working fine on Firefox 3.5. What happens when you select a file in the file chooser? Doesn't it show you a "New filename" field?

Thanks.

flo2

  • Newbie
  • *
  • Posts: 14
    • View Profile
    • Email
Re: 1.5 Upload not working "Filename is required"
« Reply #3 on: August 03, 2009, 12:51:09 pm »
It works now! I found out that the extjs-javascript was missing on the server. obviously the same problem as described here: http://forums.opengoo.org/index.php?topic=2269.msg8734#msg8734

Some strange unpacking problems under debian linux here... the folder with the javascript in it was unzipped as a file. after deleting the old files und unpacking again (using the same archive), it was ok.

Steve

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: 1.5 Upload not working "Filename is required"
« Reply #4 on: August 04, 2009, 02:23:19 am »
When I upload a file , it appear a error message as following:

Error:Failed to upload file.
or
Error:Query failed with message 'Incorrect string value: '\xC3\xFE\xA1@\xA1@...' for column 'content' at row 1'

I tried to put the file in different path and the result is same.

My System Environment:
OS: WIX XPP SP3
Web Server:Apache V2.2
Opengoo:1.5 from online upgrade
DB:MY SQL 5.1.34
Boswer: IE 8 and Firefox 3.5.1 result is same
PHP: V5
« Last Edit: August 04, 2009, 07:30:49 am by Steve »

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 1.5 Upload not working "Filename is required"
« Reply #5 on: August 04, 2009, 10:09:52 am »
Was it working successfully before the upgrade?

Steve

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: 1.5 Upload not working "Filename is required"
« Reply #6 on: August 05, 2009, 06:20:10 am »
Yes, I upgrade to 1.5 is successfully before. And I upgrade to 1.5.1 automatically. I saw the version change to V1.5.1 in righ bottom.

I test upload document again in V1.5.1 and the result is same. I find a rule is the smaller file is easy to upload successfully but not in large file. I mean smaller file means under 100k and large file is 2.*M. For smaller file, it will appear a Error:fail upload message and then show upload successful message. It is a exception! I check the finial result and confim the small file is uploaded to server successfully. Thank you!


 

anything