Author Topic: upgrade to 1.5.1, documents toolbar no longer visible  (Read 5544 times)

mrsteveman1

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
upgrade to 1.5.1, documents toolbar no longer visible
« on: August 04, 2009, 10:39:41 pm »
We were running 1.5 on Linux and had added a few documents to the system (we love it by the way), however upgrading to 1.5.1 we no longer have an editor toolbar in the documents editor.

You can see what it should look like here:

http://wiki.opengoo.org/lib/exe/detail.php/fck-editor.jpg?id=documents

Notice the buttons for bold, italic, font size, justification, indent. We no longer have those, and i have uploaded a screenshot of the current look here:



It would appear something is not loading, however i have completely reinstalled the opengoo software while preserving the config and database, and i get the same problem.

Thoughts?
« Last Edit: August 04, 2009, 10:43:46 pm by mrsteveman1 »

mrsteveman1

  • Newbie
  • *
  • Posts: 4
    • View Profile
    • Email
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #1 on: August 04, 2009, 10:44:18 pm »
Some additional info.

This is found in the log.php file:

Session "default" started at 2009-08-05T01:40:59+0000
#1 ERROR: Error: Undefined index:  id in '/var/www/html/opengoo/application/views/co/view.php' on line 112 (error code: 8 )
Time since start: 0.0931849479675 seconds


Browsers include firefox 3.5.2, safari 4.0.2, opera 10 beta 2

Server is running ubuntu 8.04.3, apache 2.2.8, and mysql 5.0.51a-3ubuntu5.4

afrofur

  • Newbie
  • *
  • Posts: 9
    • View Profile
    • Email
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #2 on: August 04, 2009, 11:44:16 pm »
Exact same problem as described above.
Web Host: PHP 5.2.5; MySQL 5.0.27; Apache 2.2.6; Linux.

Browsers: Mac OS X 10.5.7 - Safari 4.0.2; Firefox 3.0.6

Pet

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 638
  • Always mining for solutions!
    • View Profile
    • The Bet!
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #3 on: August 05, 2009, 03:15:49 am »
Same problem here myself, IIS. Cache cleared, etc.
Support OpenGoo - Sponsor a Feature! | Follow me on Twitter | OG Support Chat | Did you turn debugging on?

neapovea

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #4 on: August 05, 2009, 07:40:57 am »
After upgrade witout problem we have the same problem as described above.

thnks


ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #5 on: August 05, 2009, 05:50:43 pm »
Ok, we have found the problem. You have to replace file 'application/helpers/page.php' with the one attached here.

Please tell us whether this solves the issue.

Thanks.

Pet

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 638
  • Always mining for solutions!
    • View Profile
    • The Bet!
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #6 on: August 05, 2009, 06:10:08 pm »
No, I get this:

Quote
Parse error: syntax error, unexpected $end in D:\Domains\mydomain.com\wwwroot\clients\application\helpers\page.php on line 935

I should also add that when I try to log into OG I get this, no screens appear at all.
« Last Edit: August 05, 2009, 06:12:35 pm by Pet »
Support OpenGoo - Sponsor a Feature! | Follow me on Twitter | OG Support Chat | Did you turn debugging on?

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #7 on: August 05, 2009, 06:20:41 pm »
Can you please try again? I think your file might have corrupted when you uploaded it. It is giving an error about unexpectedly getting to the end of the file at line 935, but the file should have 956 lines.

Thanks.

Pet

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 638
  • Always mining for solutions!
    • View Profile
    • The Bet!
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #8 on: August 05, 2009, 06:33:56 pm »
Ok, downloaded a fresh copy then replaced the existing file, now I get this:

Quote
Warning: Unexpected character in input: ''' (ASCII=39) state=1 in D:\Domains\mydomain.com\wwwroot\clients\application\helpers\page.php on line 953

Parse error: syntax error, unexpected $end in D:\Domains\mydomain.com\wwwroot\clients\application\helpers\page.php on line 953
Support OpenGoo - Sponsor a Feature! | Follow me on Twitter | OG Support Chat | Did you turn debugging on?

Pet

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 638
  • Always mining for solutions!
    • View Profile
    • The Bet!
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #9 on: August 05, 2009, 06:40:12 pm »
Hmm I downloaded it again and opened it up in notepad++, it has 953 lines, here is the last line:

Code: [Select]
$page->addRelLink(with_slash(ROOT_URL).$src, 'shor
will try again a third time.....
Support OpenGoo - Sponsor a Feature! | Follow me on Twitter | OG Support Chat | Did you turn debugging on?

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #10 on: August 05, 2009, 06:41:53 pm »
I recommend you using a more reliable upload mechanism, like scp or rsync if available to you.

Pet

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 638
  • Always mining for solutions!
    • View Profile
    • The Bet!
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #11 on: August 05, 2009, 06:43:07 pm »
Okay this is totally weird.. each time I download the file, it gets smaller and smaller. Now it has 949 lines .... going to restart FF.

It's not happening on the upload, it is happening when I download from your link.
Support OpenGoo - Sponsor a Feature! | Follow me on Twitter | OG Support Chat | Did you turn debugging on?

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #12 on: August 05, 2009, 06:52:27 pm »
Lol

Pet

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 638
  • Always mining for solutions!
    • View Profile
    • The Bet!
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #13 on: August 05, 2009, 06:53:46 pm »
Okay, restarting Firefox fixed it. File looks correct, proper # of lines.
Uploaded it to my server and OG starts, but I get this whenever it starts:

Code: [Select]
Query failed with message 'Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation '=''
Error params:
File: D:\Domains\mydomain.com\wwwroot\clients\environment\library\database\adapters\AbstractDBAdapter.class.php
Line: 386

After this message, I can click anywhere and OG works, I do get the toolbar back in the editor (yay!), however I get that error above every time I restart OG.
Support OpenGoo - Sponsor a Feature! | Follow me on Twitter | OG Support Chat | Did you turn debugging on?

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: upgrade to 1.5.1, documents toolbar no longer visible
« Reply #14 on: August 05, 2009, 07:05:50 pm »
That error is fixed with this patch:
http://forums.opengoo.org/index.php?topic=2378.msg9159#msg9159

Please try it.

Thanks a lot Pet! :)

 

anything
anything