Author Topic: [1.5RC] DB-Upgrade fails: "specified key was too long..."  (Read 2876 times)

carcam

  • Full Member
  • ***
  • Posts: 127
    • View Profile
    • Gnumla!
    • Email
[1.5RC] DB-Upgrade fails: "specified key was too long..."
« on: July 17, 2009, 11:24:49 pm »
I have got exactly the same issue posted in this topic:

http://forums.opengoo.org/index.php?topic=2180.0

Nevertheless, I have not found the file to modify in order to get the 1.5RC working.

I am really excited about this release, and I can't wait more than the RC to put my hands on it.  ;)
Gnumla
Tu sitio de Joomla! en español

fcoauga

  • Jr. Member
  • **
  • Posts: 51
  • www.augadaterra.org
    • View Profile
    • Auga da Terra
Re: [1.5RC] DB-Upgrade fails: "specified key was too long..."
« Reply #1 on: July 20, 2009, 06:47:08 am »
Solved in the last three messages on this post

and mark as solved in 1.5 beta 3

Code: [Select]
    Changelog
=========
Since 1.5-beta3
---------------
        ...
- bugfix: MySQL Error: Primary key too long.
        ...

what happens?
-----
Testing Opengoo:
 external server with PHP 5.1.6 & MySQL 5.0.45
 locally server with PHP 5.2.0 & MySQL 5.0.27
Viewed with Mozilla 3.0.1 & Opera 9.60

carcam

  • Full Member
  • ***
  • Posts: 127
    • View Profile
    • Gnumla!
    • Email
Re: [1.5RC] DB-Upgrade fails: "specified key was too long..."
« Reply #2 on: July 21, 2009, 02:29:04 am »
Really sorry, I should have searched harder  :-\

Thank you for the reference, I'll try the released patch as soon as possible.
Gnumla
Tu sitio de Joomla! en español

carcam

  • Full Member
  • ***
  • Posts: 127
    • View Profile
    • Gnumla!
    • Email
Re: [1.5RC] DB-Upgrade fails: "specified key was too long..."
« Reply #3 on: July 21, 2009, 06:09:56 am »
Well, I have tried again and I can confirm that the bug is not solved, neither in the RC nor in the upgrade patch.

Nevertheless, as soon as you change the lenght of the field as it is recommended in your post, the upgrade finish successfully.

So the bug persist in this version.
Gnumla
Tu sitio de Joomla! en español

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: [1.5RC] DB-Upgrade fails: "specified key was too long..."
« Reply #4 on: July 21, 2009, 03:16:43 pm »
Seems it was corrected only for new installations but not for upgrades. It will be fixed for next release.

Thanks.

carcam

  • Full Member
  • ***
  • Posts: 127
    • View Profile
    • Gnumla!
    • Email
Re: [1.5RC] DB-Upgrade fails: "specified key was too long..."
« Reply #5 on: July 22, 2009, 04:38:04 am »
Seems it was corrected only for new installations but not for upgrades. It will be fixed for next release.

Thanks.

Great!!! I really appreciate your work. Thank you for your reply.
Gnumla
Tu sitio de Joomla! en español