Author Topic: OpenGoo 1.5 beta 3 released!  (Read 13005 times)

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
OpenGoo 1.5 beta 3 released!
« on: July 11, 2009, 03:19:10 pm »
Warning: OpenGoo 1.5 BETA 3 is not suitable for production environments. Download.

Lots of bugs have been fixed for this release and a few features have been added.

What has been improved:
  • Drag and drop now doesn’t require that you select rows before dragging, and an icon was added to make it easier to know where to drag a row.
  • Added permissions to access the time module
  • Added a checkbox next to milestone and workspace selection in tasks, to apply the selection to all subtasks
  • Fixed delete from server after X days (only delete fetched emails older than x days)
  • Fixed error when downloading revisions
  • Contact’s workspaces were not being shown
  • Dashboard - view as list was not listing documents
  • Fixed errors when using PDO Backend
  • Event email reminders were not being sent
  • Events that end at or after midnight were not being drawn correctly (week and day view)
  • Problems with group permissions (workspaces didn’t load and object listings didn’t list files in group workspaces)
  • Reports weren’t being sorted correctly and only printed first page
  • Plus more bugfixes

For a full list of changes in this version check the changelog.

Please report bugs here.

Thanks.

the_don

  • Newbie
  • *
  • Posts: 21
    • View Profile
Re: OpenGoo 1.5 beta 3 released!
« Reply #1 on: July 13, 2009, 08:05:35 am »
great work :) any news on the online/offline sync app?

Xenomorph

  • Newbie
  • *
  • Posts: 14
    • View Profile
    • Email
Re: OpenGoo 1.5 beta 3 released!
« Reply #2 on: July 13, 2009, 06:16:42 pm »
I'm sad.

Email event reminders have never worked for us.

We can Send email just fine.

Then I see that 1.5 Beta 3 has "Event email reminders were not being sent" listed as a FIX.

Se we update.

And email reminders are still NOT being sent.

Is there some setting I need to check? Again, we can send email from OpenGoo just fine.

Am I not understanding the email reminder thing?

We have a Calendar event set at 4PM. It is set to send an email to remind 15 minutes before. Well, 3:45 comes and goes, and no email.

Any ideas?

jc

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: OpenGoo 1.5 beta 3 released!
« Reply #3 on: July 14, 2009, 11:34:09 pm »
Just did an upgrade and now everything I try to do causes the toaster thingy to appear with the message "error urls is undefined", good job I backed everything up before I started. 

Anybody got any ideas ?

Double A Ron

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: OpenGoo 1.5 beta 3 released!
« Reply #4 on: July 27, 2009, 01:37:40 pm »
I'm sad.

Email event reminders have never worked for us.

We can Send email just fine.

Then I see that 1.5 Beta 3 has "Event email reminders were not being sent" listed as a FIX.

Se we update.

And email reminders are still NOT being sent.

Is there some setting I need to check? Again, we can send email from OpenGoo just fine.

Am I not understanding the email reminder thing?

We have a Calendar event set at 4PM. It is set to send an email to remind 15 minutes before. Well, 3:45 comes and goes, and no email.

Any ideas?


Dude I spent like 6 hours trying to get it to work one time and I just gave up.  :( Albeit, I'm not the shiniest pebble in the pond.

carlos

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: OpenGoo 1.5 beta 3 released!
« Reply #5 on: July 27, 2009, 03:12:55 pm »
Hi guys,

The email reminders are sent by a cron job on the server, is it correctly set up? Just in case: http://wiki.opengoo.org/doku.php/setup#setting_up_a_cron_job_on_the_server

Xenomorph

  • Newbie
  • *
  • Posts: 14
    • View Profile
    • Email
Re: OpenGoo 1.5 beta 3 released!
« Reply #6 on: July 27, 2009, 04:26:04 pm »
Yeah, I have a cron job set up that runs every 2 minutes or so. It also logs the output. I see things like "3 reminders sent" as the output, but no one ever receives a reminder.

I can send email from within the Admin screen on it as well. So if email works, and the cron jobs are being processed, how do I find out what is happening with the email reminders??

carlos

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: OpenGoo 1.5 beta 3 released!
« Reply #7 on: July 27, 2009, 06:33:30 pm »
Hi xenomorph,

Do you have your Mailing account configured correctly? You can find it in administration / configuration / mailing. I just tried it in my local version and it works as expected, try using an SMTP server instead of the default php settings.

carlos

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: OpenGoo 1.5 beta 3 released!
« Reply #8 on: July 27, 2009, 06:38:51 pm »
Hi Xenomorph,

Sorry, I answered too quickly and didn't read that you already tried sending email through the admin section and you had no problems with that.. I'm going to see if I find anything strange going on.

There is currently no way to log email errors, this is something that might be good to work on

wizardjeje

  • Guest
Re: OpenGoo 1.5 beta 3 released!
« Reply #9 on: August 03, 2009, 03:54:17 pm »
Hi jc,

The solution for url problems is very simple :
http://forums.opengoo.org/index.php?topic=2272.0

In short : you just have to clear the cache of your browser. Normally it clears itself when you close your browser.

Xenomorph

  • Newbie
  • *
  • Posts: 14
    • View Profile
    • Email
Re: OpenGoo 1.5 beta 3 released!
« Reply #10 on: August 03, 2009, 05:43:17 pm »
I'm sorry. I still don't know how to get Email reminders working.

I have email set up from the user account correctly. I can view the contents of my mailbox (IMAP settings are obviously working), and I can send email (SMTP settings are obviously working).

When I go to Administration -> Tools -> Test mail settings, any email I send is received correctly. So again, SMTP settings are correct.

Cron is running "cron.php" every 2 minutes, with output logged.

Quote
Mon Aug 3 15:30:01 CDT 2009] cron started for OpenGoo:
2009-08-03 20:31:02 - Sending reminders...
2009-08-03 20:31:02 - 1 reminders sent.

I know timezone settings are WAY off. I'm in the Central timezone. Usually GMT-6, but GMT-5 right now because of Daylight Savings. Setting things to GMT-6 results in the wrong time. Setting things to GMT-5, a Wrong timezone shows the Right times. Even when going by GMT-5 or plain GMT (which it seems like OpenGoo uses), reminders never get sent, even when the Cron.php output says it is sending reminders.

Where are the ERROR logs? Where are the email logs? Where are the SUCCESS logs? Why does it never send Reminders?
Email settings are correct and working. Cron is working.



snakewa

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: OpenGoo 1.5 beta 3 released!
« Reply #11 on: August 14, 2009, 02:10:16 am »
I have the same situation too.

I could send mail via Mass Mailer
and I can see the cron log is running, since I have check the log file.

2009-08-14 05:06:02 - Sending reminders...
2009-08-14 05:06:10 - 3 reminders sent.
2009-08-14 05:09:01 - Sending reminders...
2009-08-14 05:09:02 - 0 reminders sent.

I couldn't receive any of them

Bigal

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: OpenGoo 1.5 beta 3 released!
« Reply #12 on: August 16, 2009, 11:27:43 pm »
Two problems.
After upgrading from 1.5.1 to beta 3 and using upgrade url message 'already upgraded'  perhaps this is not a problem I do not know.

Second; getting same notification email problem as mentioned by others here. However, if I change a task, get the notification, but if the event completes, I do not get any notification email of the event completion despite notifications being set as email reminders to recipients.

snakewa

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: OpenGoo 1.5 beta 3 released!
« Reply #13 on: August 17, 2009, 12:01:51 am »
Hey gusy,

If you have problem about email reminder, check this:
http://forums.opengoo.org/index.php?topic=2461.msg9487#msg9487

Bigal

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: OpenGoo 1.5 beta 3 released!
« Reply #14 on: August 17, 2009, 12:52:01 am »
Hey gusy,

If you have problem about email reminder, check this:
http://forums.opengoo.org/index.php?topic=2461.msg9487#msg9487
Thanks, but the originator email address is defined.
I have also followed instructions on running cron as a system task on the server. Have done it in a slightly different way since using HELM server:
Web Scheduled task as project/cron.php, fired off every 10 minutes.
The scheduler shows the task as being done without errors, but every time its fired there is no log about emails in log.php. Still, the reminder notifications are not being sent.
define debug=TRUE.

So there is something else thats happening but I'd like to see some semblance of a log of the events which is not happening at all.

 

anything
anything