Author Topic: 1.5 beta error upgrading from 1.4.1  (Read 3987 times)

fcoauga

  • Jr. Member
  • **
  • Posts: 51
  • www.augadaterra.org
    • View Profile
    • Auga da Terra
1.5 beta error upgrading from 1.4.1
« on: July 06, 2009, 07:02:35 pm »
This is the error message, (debug=true)

Notice: Uninitialized string offset: -1 in E:\parawebphp\opengoo\environment\functions\general.php on line 453

Fatal error: Call to undefined method UserWsConfigOptions::getdefaultoptionvalue() in E:\parawebphp\opengoo\application\functions.php on line 396

 ??? Too much for mine  :'(
-----
Testing Opengoo:
 external server with PHP 5.1.6 & MySQL 5.0.45
 locally server with PHP 5.2.0 & MySQL 5.0.27
Viewed with Mozilla 3.0.1 & Opera 9.60

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 1.5 beta error upgrading from 1.4.1
« Reply #1 on: July 07, 2009, 01:23:54 pm »
Hi, if you are testing on a copy of another installation try deleting file 'cache/autoloader.php'.

fcoauga

  • Jr. Member
  • **
  • Posts: 51
  • www.augadaterra.org
    • View Profile
    • Auga da Terra
Re: 1.5 beta error upgrading from 1.4.1
« Reply #2 on: July 07, 2009, 07:42:07 pm »
Checked with same results for the firs line....

This is the message (more complete attached) now.

Really, the column 'updated_by_id' not exists for the field 'og_users' (checked in database).


-----
Testing Opengoo:
 external server with PHP 5.1.6 & MySQL 5.0.45
 locally server with PHP 5.2.0 & MySQL 5.0.27
Viewed with Mozilla 3.0.1 & Opera 9.60

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: 1.5 beta error upgrading from 1.4.1
« Reply #3 on: July 08, 2009, 11:30:06 am »
Hi,

this was an update error, that is only happening when trying to updrate from 1.4.1 or older versions, this will be fixed for next updates.
In your case, as you have already updated you can run this script in your database to add this field:
Code: [Select]
ALTER TABLE `og_users` ADD COLUMN `updated_by_id` int(10) unsigned default NULL;

regards

fcoauga

  • Jr. Member
  • **
  • Posts: 51
  • www.augadaterra.org
    • View Profile
    • Auga da Terra
Re: 1.5 beta error upgrading from 1.4.1
« Reply #4 on: July 08, 2009, 03:03:50 pm »
Great! solved this part but...

the first error is now present:

"Notice: Uninitialized string offset: -1 in E:\parawebphp\opengoo\environment\functions\general.php on line 453"

Additionally "missing lang.js" is present
-----
Testing Opengoo:
 external server with PHP 5.1.6 & MySQL 5.0.45
 locally server with PHP 5.2.0 & MySQL 5.0.27
Viewed with Mozilla 3.0.1 & Opera 9.60

alvarotm01

  • Administrator
  • Sr. Member
  • *****
  • Posts: 335
    • View Profile
    • Email
Re: 1.5 beta error upgrading from 1.4.1
« Reply #5 on: July 08, 2009, 03:37:56 pm »
Try adding this line in 'application/controllers/FilesController.class.php' before line nº 1768
Code: [Select]
$old_memory_limit = ini_get('memory_limit');
I think this is why that error in general.php is occurring.

which is the missing lang that appears? or it only shows "Missing lang.js : "?

fcoauga

  • Jr. Member
  • **
  • Posts: 51
  • www.augadaterra.org
    • View Profile
    • Auga da Terra
Re: 1.5 beta error upgrading from 1.4.1
« Reply #6 on: July 09, 2009, 03:42:50 pm »
Line changed but without exit. You can see the error in both screens attached and more stuff that probably informs you.

In the message that appears "all" is translate as "öszzes", as you can see.

I suppose that you prefer that I continue test the upgrade from 1.4.1...
-----
Testing Opengoo:
 external server with PHP 5.1.6 & MySQL 5.0.45
 locally server with PHP 5.2.0 & MySQL 5.0.27
Viewed with Mozilla 3.0.1 & Opera 9.60

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: 1.5 beta error upgrading from 1.4.1
« Reply #7 on: July 09, 2009, 05:18:58 pm »
Hi,

Insert this line on file 'environment/functions/general.php', on line 453, so that it is the second line in function 'php_config_value_to_bytes':
Code: [Select]
if ($val == "") return 0;

Thanks.

fcoauga

  • Jr. Member
  • **
  • Posts: 51
  • www.augadaterra.org
    • View Profile
    • Auga da Terra
Re: 1.5 beta error upgrading from 1.4.1
« Reply #8 on: July 10, 2009, 09:45:27 am »
Great, solved with this line.

Thanks
-----
Testing Opengoo:
 external server with PHP 5.1.6 & MySQL 5.0.45
 locally server with PHP 5.2.0 & MySQL 5.0.27
Viewed with Mozilla 3.0.1 & Opera 9.60

Bigal

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: 1.5 beta error upgrading from 1.4.1
« Reply #9 on: July 28, 2009, 11:08:46 am »
Hi, if you are testing on a copy of another installation try deleting file 'cache/autoloader.php'.
Worked for me tks new upgrade stable looks really good thanks for the major overhaul on email.

 

anything