Author Topic: Images blocked in Incoming Emails  (Read 3337 times)

ritmo

  • Freshman
  • *
  • Posts: 10
    • View Profile
Images blocked in Incoming Emails
« on: April 11, 2016, 03:31:12 am »
I have a Feng Office Community version (v3.4.1) installation, and the most frustrating issue right now is that images in incoming emails (most notably a logo in the email signature) are being blocked. Outbound emails are apparently unaffected.

I've tried enabling the related option in Email setup/configuration to no avail. Even with the displayed notice of "blocked images" in the incoming email - clicking on this makes no difference whatsoever.

The simple test performed is as follows:
1. Create test email with logo image in signature.
2. Send to Gmail account. Result: Image seen in signature, no problem.
3. Send email to another Feng Office account. Result: No image displayed in incoming email. 'Alt Text' text seen instead.

What am I missing? Any suggestions welcome.

Thanks,
David


steveg

  • Full Member
  • ***
  • Posts: 167
    • View Profile
Re: Images blocked in Incoming Emails
« Reply #1 on: April 13, 2016, 03:57:52 pm »
This could be gmail that is the problem, as they move images to their own servers and then serve them.

Does it work if you just do a 2 step test?

1. Create test email with logo image in signature in GMAIL.
2. Send email to another Feng Office account.

If that works, then it is google not feng that is to blame...

ritmo

  • Freshman
  • *
  • Posts: 10
    • View Profile
Re: Images blocked in Incoming Emails
« Reply #2 on: April 14, 2016, 06:25:14 am »
Hi Steve,

Thanks for taking the time to respond.

As to your suggestion: I did as you suggested, creating an email in Gmail and pasting the logo into the body of the message. I sent this message to two separate destinations: one a FengOffice client, and another an email client (Outlook) connected to a standalone hosting account (separate domain).
 
Sure enough, sending it to the FengOffice client stripped the logo away, leaving the alternate text. Sending it to the standalone hosting account worked fine.

I should tell you that I now have three (3) separate FengOffice installations, one of which is the latest release (v3.4.1), and the others the second-to-last version (v3.4.0.17). They all appear to behave the same way where email is concerned.

Based on the above evidence, and the simple fact that email messages sent between FengOffice installations suffer the same fate, I think the FengOffice installations are somehow at fault. Gmail looks clean.

I honestly thought it would have been a simple setting - maybe SPAM/security-related, but not having any SPAM filter in place at the server end, I've ruled that out.

I have no idea what might be causing this - do you?

Regards,
David

steveg

  • Full Member
  • ***
  • Posts: 167
    • View Profile
Re: Images blocked in Incoming Emails
« Reply #3 on: April 18, 2016, 11:21:53 am »
I've checked on our installation of FO and no images are stripped from emails.

So, it is no FO that is the problem, but perhaps somewhere in your settings, either server or FO settings.

In email options in FO, what do you have "Block email images" set to?  Perhaps this is set to "yes"?  It is configurable on a per user basis.

ritmo

  • Freshman
  • *
  • Posts: 10
    • View Profile
Re: Images blocked in Incoming Emails
« Reply #4 on: April 19, 2016, 05:56:11 am »
Hi Steve,

Thanks for checking on your installation and reporting your findings. BTW: What release version FO is your installation?

To answer your question about the settings: yes, I have checked all the email settings you mentioned. They are all set individually to "No".

I should also mention that the three FO installations I have are installed on two different servers (hosting providers). Is yours installed locally, by any chance?


David

steveg

  • Full Member
  • ***
  • Posts: 167
    • View Profile
Re: Images blocked in Incoming Emails
« Reply #5 on: April 20, 2016, 10:08:41 am »
We are 3.4.0.17 - just haven' thad the time to upgrade to 3.4.1 yet...

We run our install on a Debian 7 server out of a datacentre.

natalia.martinez

  • Administrator
  • Freshman
  • *****
  • Posts: 47
    • View Profile
Re: Images blocked in Incoming Emails
« Reply #6 on: May 02, 2016, 04:00:09 pm »
Hi all!

@David, could you send us an example eml file where you cannot see the images.

Thanks

Natalia

ritmo

  • Freshman
  • *
  • Posts: 10
    • View Profile
Re: Images blocked in Incoming Emails
« Reply #7 on: May 04, 2016, 11:35:28 pm »
Hi Natalia,

What's the best way to send you this information? I've made 3 screenshots that illustrate what I'm seeing - on both the sending and receiving ends of a 'conversation'.

BTW: My Feng Office installation is in a sub-domain - if that matters any. I also checked the TMP folder and not being sure exactly what you meant by Apache having 'write' permissions, I set the permissions to 775 and then 777. Neither of these made any difference to the incoming mail.
Could htaccess settings have any effect on this?

Thanks for your attention to this issue.


Regards,

David