Author Topic: 3.2.3 Error 500 and Debug mode makes Overview work  (Read 3725 times)

Marcusov

  • Newbie
  • *
  • Posts: 9
    • View Profile
3.2.3 Error 500 and Debug mode makes Overview work
« on: August 20, 2015, 01:48:51 am »
I just upgraded to 3.2.3 and the Overview screen doesn't work for anyone, it gives an Internal Server Error 500. In the course of trying to determine the issue I turned debugging on (in the config.php file for FO) and just having that on makes it so everyone is able to see their Overview screen. I can leave it on, but would rather know how to fix this behavior.
I was able to get some errors logged in the log.php file, and I'm unsure if it is related the error posted there is: Illegal offset type in isset or empty in '/home3/public_html/fengoffice/environment/classes/dataaccess/DataObject.class.php' on line 374 (error code: 2)

Anyone have any ideas on this? If I find a solution on my own I'll post the answer. Thanks!

marsian

  • Freshman
  • *
  • Posts: 39
    • View Profile
Re: 3.2.3 Error 500 and Debug mode makes Overview work
« Reply #1 on: August 20, 2015, 03:43:02 am »
Can you post some specifications of your webserver? PHP Version etc.?

Marcusov

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: 3.2.3 Error 500 and Debug mode makes Overview work
« Reply #2 on: August 20, 2015, 01:47:39 pm »
Marsian, Thank you for the reply.
PHP is version 5.4.43
MySQL is version 5.5.42-37.1
Apache: 2.2.29

Additionally today we have found something that may be the cause, we get an error when trying to use the "view as list" option, the error is: "fengoffice/application/views/dashboard/init_overview.php' doesn't exists"

And indeed the init_overview.php file doesn't exist, and isn't present in the latest build. It looks like the initial call to this file is coming from the FO root folder/init.php file on line 177
But I don't know what to do about it, any suggestions? Some additional Error info is below.

Thanks!!

Error (FileDnxError)
File '/fengoffice/application/views/dashboard/init_overview.php' doesn't exists
Error params:
File:   /fengoffice/environment/classes/controller/PageController.class.php
Line:   317
File path:   /fengoffice/application/views/dashboard/init_overview.php
Backtrace:
#0 /fengoffice/environment/classes/controller/PageController.class.php(120): PageController->getTemplatePath()
#1 /fengoffice/environment/classes/Env.class.php(135): PageController->getContent()
#2 /fengoffice/init.php(177): Env::executeAction('dashboard', 'init_overview')
#3 /fengoffice/index.php(7): require('/home...')
#4 {main}
Can you post some specifications of your webserver? PHP Version etc.?
« Last Edit: August 20, 2015, 03:49:44 pm by Marcusov »

Marcusov

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: 3.2.3 Error 500 and Debug mode makes Overview work
« Reply #3 on: August 25, 2015, 12:12:45 pm »
Is this a bug in the code, being that it appears that the code is referencing files that don't exist?

bukbr

  • Jr. Member
  • **
  • Posts: 73
    • View Profile
Re: 3.2.3 Error 500 and Debug mode makes Overview work
« Reply #4 on: August 30, 2015, 06:17:40 pm »
Same problem here! Overview comes with Error 500.

I just upgraded to 3.2.3 and the Overview screen doesn't work for anyone, it gives an Internal Server Error 500. In the course of trying to determine the issue I turned debugging on (in the config.php file for FO) and just having that on makes it so everyone is able to see their Overview screen. I can leave it on, but would rather know how to fix this behavior.
I was able to get some errors logged in the log.php file, and I'm unsure if it is related the error posted there is: Illegal offset type in isset or empty in '/home3/public_html/fengoffice/environment/classes/dataaccess/DataObject.class.php' on line 374 (error code: 2)

Anyone have any ideas on this? If I find a solution on my own I'll post the answer. Thanks!

 

anything
anything