Author Topic: Task Reminders are not being sent  (Read 2118 times)


  • Freshman
  • *
  • Posts: 23
    • View Profile
    • Email
Task Reminders are not being sent
« on: June 18, 2015, 12:46:30 am »
Good Evening,

 I am currently running two installs of the community version. is the primary, I've been running for over a year, upgrading periodically. Reminders are working great from this install.

I recently installed a new version to run for another group, that is running 3.1.3 right now and will not send email reminders in the cron job.

I did another new clean install of version 3.2rc to do some testing, and that also is not sending the email reminders.    Mail systems are set up correctly because notices that a new task has been assigned are sent just fine, and I ran test emails, and they are working fine.  But they do not work in the Cron Job.   I've also gone through all of the settings line by line to make sure they were set exactly the same as the installation that is working.

When I run the cron job on the install that is working I get this:

2015-06-18 02:55:10 - Sending reminders...
2015-06-18 02:55:12 - 4 reminders sent.
2015-06-18 02:55:12 - Checking for sharing table pending updates...
2015-06-18 02:55:12 - No permission groups need to be updated.
2015-06-18 02:55:12 - Checking email...
2015-06-18 02:55:12 - 0 emails fetched.
2015-06-18 02:55:13 - Sending outbox emails...
2015-06-18 02:55:13 - End Sending outbox emails.

But when I run the cron job on the latest two installs I only get:

2015-06-18 03:37:09 - Sending reminders...
2015-06-18 03:37:10 - 5 reminders sent.

So it seems something is blocking the cron job from finishing and it just never gets around to sending the messages. 

I don't know how to figure out what it is that is blocking it from working correctly.  I've attached the /cache/log.php file for review.  I've gone through and done the CHMOD suggested in the log file, but it still keeps giving me the error message.  The other issues I don't know how to fix.

I've been dealing with this for a few days now, any help/suggestions would be GREATLY appreciated!! Thank you.


  • Freshman
  • *
  • Posts: 23
    • View Profile
    • Email
Re: Task Reminders are not being sent
« Reply #1 on: June 19, 2015, 11:20:21 am »
I found a way to make it work, but I don't know if it fixed any type of bug.

What I did was I took my good install ( and copied all the files to overwrite the other installation, reverted the config files, and then upgraded back to 3.2, and now it works.

So I'm guessing some file somewhere is different that copying the files over managed to fix, but no idea which file it was. :(