Author Topic: SSL-Verschlüsselung bei Web de  (Read 1812 times)

Harald Posch

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
    • Email
SSL-Verschlüsselung bei Web de
« on: April 01, 2014, 04:39:06 am »
Hallo zusammen,

vielleicht kann mir ja jemand helfen?

Ich hab seit letzter Woche ein Problem mit meinen Mail von Web de. Geht ja jetzt nur noch mit SSL-Verschlüsselung.
Was muss ich denn da genau einstellen?
Ich sehe nur 3 Punkte wo ich SSL auswählen kann und bei 2 davon kann ich einen Post eingeben, Aber wo kann ich denn den Schlüssel und das Passwort für das Zertifikat eingeben, das ich auf meinem PC installiert habe?

Vielen Dank für eure Mühe.

Gruss
Harald
« Last Edit: April 01, 2014, 04:50:05 am by Harald Posch »

Harald Posch

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
    • Email
Re: SSL-Verschlüsselung bei Web de
« Reply #1 on: April 19, 2014, 07:08:28 am »
OK, den Empfang hab ich nun hingekriegt. Einfach nur die Häkchen bei SSL setzen und einmal TSL auswählen ;)
Allerdings kann nichts mehr verschicken. Vielleicht hat ja hier jemand einen Tipp?

Gruss
Harald

Henry

  • Full Member
  • ***
  • Posts: 159
    • View Profile
Re: SSL-Verschlüsselung bei Web de
« Reply #2 on: May 01, 2014, 05:02:26 pm »
Hallo Harald,

schau mal bitte im Ordner cache in die Datei log.php, ob du nach dem Senden einer Mail einen ähnlichen Fehler bekommst.

Session "default" started at 2014-05-01T19:37:45+0000
#1 ERROR: Error: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:
    error:140770FC:lib(20):func(119):reason(252) in '/volume1/web/feng/library/swift/lib/classes/Swift/Transport/StreamBuffer.php' on line 257 (error code: 2)
#2 ERROR: Error: stream_socket_client(): Failed to enable crypto in '/volume1/web/feng/library/swift/lib/classes/Swift/Transport/StreamBuffer.php' on line 257 (error code: 2)
#3 ERROR: Error: stream_socket_client(): unable to connect to ssl://xxxxxxxxxx:25 (Unknown error) in '/volume1/web/feng/library/swift/lib/classes/Swift/Transport/StreamBuffer.php' on line 257 (error code: 2)
#4 ERROR: ERROR SENDING EMAIL: #0 /volume1/web/feng/library/swift/lib/classes/Swift/Events/SimpleEventDispatcher.php(157): Swift_Plugins_LoggerPlugin->exceptionThrown(Object(Swift_Events_TransportExceptionEvent))
    #1 /volume1/web/feng/library/swift/lib/classes/Swift/Events/SimpleEventDispatcher.php(134): Swift_Events_SimpleEventDispatcher->_bubble(Object(Swift_Events_TransportExceptionEvent), 'exceptionThrown')
    #2 /volume1/web/feng/library/swift/lib/classes/Swift/Transport/AbstractSmtpTransport.php(363): Swift_Events_SimpleEventDispatcher->dispatchEvent(Object(Swift_Events_TransportExceptionEvent), 'exceptionThrown')
    #3 /volume1/web/feng/library/swift/lib/classes/Swift/Transport/AbstractSmtpTransport.php(117): Swift_Transport_AbstractSmtpTransport->_throwException(Object(Swift_TransportException))
    #4 /volume1/web/feng/library/swift/lib/classes/Swift/Mailer.php(80): Swift_Transport_AbstractSmtpTransport->start()
    #5 /volume1/web/feng/plugins/mail/application/helpers/MailUtilities.class.php(800): Swift_Mailer->send(Object(Swift_Message))
    #6 /volume1/web/feng/plugins/mail/application/controllers/MailController.class.php(844): MailUtilities->sendMail('xxxxxx...', 'xxxxxx...', Array, 'test', '<div style="fon...', '', '', NULL, 25, 'xxxxxx', '8?8: <8!', 'text/html', 'ssl', '<og.xxxxx....', '', Array, 'Message-ID: <og...', 2)
    #7 /volume1/web/feng/environment/classes/controller/Controller.class.php(76): MailController->send_outbox_mails()
    #8 /volume1/web/feng/environment/classes/controller/PageController.class.php(62): Controller->execute('send_outbox_mai...')
    #9 /volume1/web/feng/environment/classes/Env.class.php(129): PageController->execute('send_outbox_mai...')
    #10 /volume1/web/feng/init.php(173): Env::executeAction('mail', 'send_outbox_mai...')
    #11 /volume1/web/feng/index.php(9): require('/volume1/web/fe...')
    #12 {main}
#5 DEBUG: Could not send email: Connection could not be established with host xxxxxxxxxxxx.com [ #0]
    Log data:
    ++ Starting Swift_SmtpTransport
    !! Connection could not be established with host xxxxxxxxxxxx.com [ #0]
    mail_id=22846
#6 DEBUG: Swift returned sentOK = false after sending email
    mail_id=22846
Time since start: 22.476386070251 seconds


Sollte dies der Fall sein, könnte das auf diesen Bug zurück zuführen sein.
https://bugs.php.net/bug.php?id=54511

Ich habe das Problem, dann wie folgt umgangen:
In folgendem Pfad gibt es die Datei StreamBuffer.php, die muß leicht abgeändert werden, dann geht es bei mir zumindest mit dem senden über SSL-verschlüsselter Verbindungen.
library\swift\lib\classes\Swift\Transport

die Funktion private function _establishSocketConnection() wie folgt ändern:

Zeile 257:
$this->_stream = @stream_socket_client($host.':'.$this->_params['port'], $errno, $errstr, $timeout, STREAM_CLIENT_CONNECT, stream_context_create($options));


ersetzen mit


if ($this->_params['protocol'] == 'ssl' || $this->_params['protocol'] == 'tls'){
         $context = stream_context_create(array('ssl' => array('SNI_server_name' => $host), ));
         $this->_stream = stream_socket_client("tcp://".$this->_params['host'].":".$this->_params['port'], $errno, $errstr, $timeout, STREAM_CLIENT_CONNECT, $context);

      }else {
         $this->_stream = @stream_socket_client($host.':'.$this->_params['port'], $errno, $errstr, $timeout, STREAM_CLIENT_CONNECT, stream_context_create($options));
      }



leider muss dies bei jedem Update des FengOffice wiederholt werden.
Ich hoffe es hilft dir.