Author Topic: Files corrupted after upgrade to 1.3  (Read 3070 times)

marcos.zy

  • Newbie
  • *
  • Posts: 8
    • View Profile
Files corrupted after upgrade to 1.3
« on: March 31, 2009, 08:13:27 pm »
Hi,

I had inumerous files (.PDF) uploaded on my OpenGoo 1.2.x, and all was ok until I upgrade to 1.3. Now, when I download some file, I get only "blank" files, without any content.

Someone has some idea of what could be the cause of this or if is there some way to correct it (I think no)?

Or, someone had experienced a similar issue? :(

Best Regards.  :)

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Files corrupted after upgrade to 1.3
« Reply #1 on: April 07, 2009, 10:42:51 am »
Does this happen only with PDF files? What about new PDF files? What file storage system are you using? (check Administration -> Configuration -> General -> File storage)

marcos.zy

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Files corrupted after upgrade to 1.3
« Reply #2 on: April 13, 2009, 04:22:58 pm »
Hello,

No, all files was corrupted. I had .jpg and .pdf files, and both file types was corrupted.

I am using "file system (sistema de arquivos)" option.

Thanks again. :)
« Last Edit: April 13, 2009, 04:24:42 pm by marcos.zy »

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Files corrupted after upgrade to 1.3
« Reply #3 on: April 14, 2009, 07:17:00 pm »
You should check in the upload folder if files are correct in there or if they somehow got corrupted physically. Use this script that I'm attaching to see the path in the upload folder for each file in OpenGoo, so that you can check if it is OK (just place it in your OpenGoo's root dir and access it through a browser). Also you can try downloading the file from there by clicking Download or if you click the path it will try to download it directly from the upload folder (if you didn't configure your webserver to prevent it).

marcos.zy

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Files corrupted after upgrade to 1.3
« Reply #4 on: April 15, 2009, 04:43:09 pm »
Hello,

I used the attached php script, and saw the upload directory.

Both download through the script, or accessing the upload folder, the files are corrupted. For example, I have files with the below structure:

upload/e0589/074fa/d04a7/e35c9e2b0ca47c6c25ffc32b6

Even acessing through FTP the upload/e0589/074fa/d04a7/ directory, downloading the e35c9e2b0ca47c6c25ffc32b6 file and renaming it to e35c9e2b0ca47c6c25ffc32b6.pdf (it was a PDF), it still corrupted.

I really don't understand what happened, and think that I have lost all my data. Of course I can upload all again, but my intention was to have a secure and acessible place to store and manage docs for me and my associates.
« Last Edit: April 15, 2009, 04:46:51 pm by marcos.zy »

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: Files corrupted after upgrade to 1.3
« Reply #5 on: April 17, 2009, 05:43:52 pm »
Uploading a new file produces a corrupted file?

marcos.zy

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Files corrupted after upgrade to 1.3
« Reply #6 on: April 17, 2009, 06:10:55 pm »
No.

Only my old files was corrupted during/after the upgrade process. :(