Author Topic: Timezone wrong in cron jobs  (Read 5018 times)

Blinkiz

  • Freshman
  • *
  • Posts: 24
    • View Profile
Timezone wrong in cron jobs
« on: August 06, 2010, 04:03:10 am »
Hello
The timezone is shown in GMT time when I get event reminders by email. The text in the email has the GMT time instead of the users timezone.

Here is my cron job:
Code: [Select]
* * * * * wget -O - -q https://localhost/cron.php --no-check-certificate
Using Feng Office 1.7 on Ubuntu 10.04.
Please advice
« Last Edit: August 06, 2010, 11:26:24 am by Blinkiz »

cabeza

  • Administrator
  • Hero Member
  • *****
  • Posts: 1004
    • View Profile
    • Feng Office
Re: Timezone wrong in cron jobs
« Reply #1 on: August 06, 2010, 11:14:34 am »
What Feng Office version are you using?

Blinkiz

  • Freshman
  • *
  • Posts: 24
    • View Profile
Re: Timezone wrong in cron jobs
« Reply #2 on: August 06, 2010, 11:26:00 am »
Ops, forgot the version number. It's 1.7

cabeza

  • Administrator
  • Hero Member
  • *****
  • Posts: 1004
    • View Profile
    • Feng Office
Re: Timezone wrong in cron jobs
« Reply #3 on: August 06, 2010, 11:32:54 am »
We'll fix it for 1.7.1.
Best

iTristan

  • Newbie
  • *
  • Posts: 10
    • View Profile
    • Email
Re: Timezone wrong in cron jobs
« Reply #4 on: October 18, 2010, 09:56:20 am »
Yes please! This one is messing us up to no end!

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1819
    • View Profile
    • Email
Re: Timezone wrong in cron jobs
« Reply #5 on: November 01, 2010, 02:37:48 pm »
This has already been fixed by now.. If you still have problems please let us know

Best regards,
Francisco
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!

matsonda

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Timezone wrong in cron jobs
« Reply #6 on: January 19, 2011, 08:24:55 pm »
I just installed version 1.7.3.1 and I am getting the same problem for 1 user, but not the other users.  I set up an event for 10:30 am.  I invite users belonging to a company whose timezone is Pacific.  The resulting email for this 1 user fails to subtract the 8 hours and instead reads 18:30.  I have switched the users Company.  I have changed the users email address.  Nothing seems to work.  Any ideas? 

I also set the default for am/pm instead of 24 time, and yet the email is formatted to 24 time.  (Great solution overall!  Thanks)
« Last Edit: January 19, 2011, 08:46:12 pm by matsonda »

matsonda

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Timezone wrong in cron jobs
« Reply #7 on: January 24, 2011, 05:44:03 pm »
Just noticed that my activity section on the Dashboard is in 24 hour time, yet I have selected am/pm.  Also the 24 time displayed in my Activity Dashboard window is 8 hours off. 

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1819
    • View Profile
    • Email
Re: Timezone wrong in cron jobs
« Reply #8 on: February 01, 2011, 10:30:03 am »
Regarding the user problem notification, have you checked the og_users table and checked if that user GMT is 0 or -8?

About the am/pm default setting, have you checked your user account settings if it is in am/pm or 24 hs? Because default settings are valid for the new users if I am not mistaken

Best regards,
Francisco
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!

matsonda

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Timezone wrong in cron jobs
« Reply #9 on: February 02, 2011, 09:22:35 pm »
In the og_user table that user in question was 0.0 in the timezone field instead of -8.0!  Problem solved! Thanks!


Second problem persists.  My user default settings are AM/PM or No to the item : Use 24 hours format for time descriptions           

I want to see AM/PM time in the Activity section of the Overview, but instead I'm seeing all time in 24 hour format.  Any ideas?

Blinkiz

  • Freshman
  • *
  • Posts: 24
    • View Profile
Re: Timezone wrong in cron jobs
« Reply #10 on: April 01, 2011, 04:02:54 am »
Hi
Summer time came last weekend. So instead of being in GMT +01:00, we in Sweden are in GMT +02:00.
It does not seems like Feng can handle this. DST changes. Is this correct? Bug? Feature request?

Linux server clock was automatic updated and pushed one hour forward. Problem is that notifications (cron jobs) is done one hour late.

My users have this setting:
Auto-detect user timezone from browser: No
(GMT +01:00) Amsterdam, Berlin, Rome, Copenhagen, Brussels, Madrid, Paris

franponce87

  • Administrator
  • Hero Member
  • *****
  • Posts: 1819
    • View Profile
    • Email
Re: Timezone wrong in cron jobs
« Reply #11 on: April 04, 2011, 03:01:03 pm »
Hi
Summer time came last weekend. So instead of being in GMT +01:00, we in Sweden are in GMT +02:00.
It does not seems like Feng can handle this. DST changes. Is this correct? Bug? Feature request?

Linux server clock was automatic updated and pushed one hour forward. Problem is that notifications (cron jobs) is done one hour late.

My users have this setting:
Auto-detect user timezone from browser: No
(GMT +01:00) Amsterdam, Berlin, Rome, Copenhagen, Brussels, Madrid, Paris

Hello, that is because you have to enable the autodetect user timezone from browser.

Best regards,
Francisco
Would you like to install Feng Office Professional or Enterprise Edition in your servers? No problem! Read this article!