Author Topic: List of all extensions needed for correct work of OpenGoo  (Read 2186 times)

setekh

  • Newbie
  • *
  • Posts: 35
    • View Profile
List of all extensions needed for correct work of OpenGoo
« on: February 26, 2009, 06:27:24 am »
I was wondering if there is a list, or can the developers find some time to compile one of the extensions that are needed for the correct work of opengoo. That way we can install apache and php with only the needed extensions. That way the installation will be as fast as possible and we will not worry for too much updates and exploits. Thanks.

ignacio

  • Hero Member
  • *****
  • Posts: 1703
    • View Profile
Re: List of all extensions needed for correct work of OpenGoo
« Reply #1 on: February 27, 2009, 06:01:57 pm »
I don't have a complete list, but these are the ones I can think of:

- gd
- mysql (alternatively PDO and pdo_mysql)
- mbstring (without it there can be some errors when handling languages other than english)
- iconv
- zip (for compressing  extracting zip files, backups, automatic upgrade and some public tools)
- json (recommended but not necessary)
- SimpleXML (for upgrade checking)

technomensch

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: List of all extensions needed for correct work of OpenGoo
« Reply #2 on: March 18, 2009, 11:05:41 pm »
Some hosting providers do not offer some of these extensions by default, and installing them would require me to install a custom version of php.

My hosting provider allows this, but requires a lot of work.  Other than the manual upgrade, are there any plans to enhance the upgrades?  Perhaps through subversion checkout?

Also, without the .zip extension, that is going to make it tough to upload multiple files.  Is there any way that I could upload files into a directory onto my host, then tell opengoo where the files are, then it copies or moves the files into where they should be for them to work in the program?

 

anything
anything