Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - shodgman

Pages: [1] 2
1
Feng Office 2 / Re: So....really....what's happenning to Feng Office?
« on: November 20, 2012, 02:59:14 am »
I second that!

For months now I have watched as people try to upgrade from 1.7.5 to whatever the latest version 2 release is.  All I see are errors being reported.  These appear serious enough to stop me trying again.  I have tried and it was a mini disaster. Lots of errors.  I tried everything that was reported and nothing worked.  I asked questions and received nothing that helped.

I do not believe I am alone in this situation.
Until there is an upgrade path that works reliably, I will not be going to Ver 2 or recommending anybody else use Ver 2. 

For now, the project seems to be a dead end.  Unless you are happy to re-key your data everytime there is a major version upgrade.

This is a real pity.  The project is a great product.  Why is it so hard to provide a viable upgrade path?
---
SteveH

2
Feng Office 2 / Re: DB Error when upgrading from 2.01 to 2.1
« on: August 03, 2012, 03:33:56 am »
Before conversion
og_shared_objects has zero records
og_searchable_objects has 1704 records


BTW, I have been checking cache/log.php whenever I did the conversion.  complete_migration is not adding anything.

Thanks
--
SteveH

3
Feng Office 2 / Re: DB Error when upgrading from 2.01 to 2.1
« on: August 02, 2012, 03:31:58 am »
Thanks for the clarification regarding the plugins.
I actually tried with and without the plugin update I believe.

What about the version.php still saying 1.7.5 AFTER the upgrade to 2.01 ??

To clarify:
php FENG_ROOT/public/upgrade/complete_migration.php  takes a number of minutes then the console prompt returns.  I then check the fo_processed_objects table and there are ZERO records.  That is my problem.

Can you please suggest where I might start looking for the solution?

 Alternatively, when will there be a proper release that does the upgrade itself?
Thanks for getting back to me,
---
SteveH

4
Feng Office 2 / Re: DB Error when upgrading from 2.01 to 2.1
« on: August 01, 2012, 08:32:34 pm »
Well, I am now having problems going from 1.7.5 to 2.0.1
I am following the instructions in www <dot> fengoffice <dot> com/web/wiki/doku.php/migration
I have extracted fengoffice_2.1.0.zip into my folders as per the instructions.
I complete steps 1 through 6 fine

Question:  After step 7, upgrade to 2.0.1 should I do the plugin update?  If I do then the log shows errors looking for the PLUGINS path.
As per the migration instructions I did NOT copy the init.php into the root folder.  Question: Should I be copying the new files  into the root folder?

N.B. version.php is still 1.7.5 at this point

On step 8, the ~complete_migration.php step, I am finding zero records in the fo_processed_objects table.  Running the script again gets the same result.

So, I am completely confused as this part "Just Worked" previously.
Can anyone please shed some light on this?  I have tried all possible combinations that I can think of over the last 48 hours.  
Thanks,
---
Steve H

5
Feng Office 2 / Has anyone successfully upgraded from 1.7.5 to 2.1?
« on: July 19, 2012, 08:19:38 pm »
Recently I tried to upgrade from 1.7.5 to 2.1.  However, after the conversion to 2.0.1 there was an error getting to 2.1.

A number of us have posted and confirmed a bug in this stage of the upgrade process. see www <dot> fengoffice <dot> com and add /web/bugs/view.php?id=3960 as the detail on the URL.

I just wondered if we were alone or just special :-)

Clean installs of 2.1 work fine and I would like to be using it with the better permissions setup and Google calendar sync etc.  However, all my data is in 1.7.5 as I am worried that the 2.0.1 data might have been bad.

Can anyone help with suggestions on how to get around this issue please?
Thanks
SteveH

6
Thanks for the update to the documentation.  I now have a better understanding of how the usage and permissions has been designed.  I had a different idea on how I thought it worked.

7
Installation problems / Re: Upgrade from 201 to 21rc2 DB failure
« on: July 18, 2012, 09:31:58 pm »
Not me!  No reply as yet and the bug reported about this issue has not yet been acknowledged yet.

So, I can only assume that people have NOT been able to upgrade from 1.7.5 to 2.1
---
Steve

8
I am using Ver 2.1
Can someone please point me at any documentation on how the new security and user access settings are supposed to work?
And, just what parts of it work in this version?

From what I can see it is not at all obvious and seems entirely unworkable with respect to interacting with external users i.e. as a CRM system.

Surely not?  Please tell me I am wrong and do not know how to use the new settings.
Thanks,
--
SteveH

9
Feng Office 2 / Re: DB Error when upgrading from 2.01 to 2.1
« on: July 16, 2012, 09:56:44 pm »
Thanks for letting me know.
Now we wait...  :)

10
It seesm that the permissions have changed a lot in 2.1
I have a clean install and have setup companies with users.
 When setting their permissions I cannot see the checkbox for
"Assign Tasks to members of owner company"  OR
"Assign tasks to members of other clients"

I am assuming that the People Permissions that is there now when setting the user permissions is meant to replace this and make it more sophisticated.
However... How to I set it up?

I have tried lots of combinations of settings but no matter what I have done, when I try to assign a task as a user from an external company, I do not see other users in my drop down list.

Can somebody please explain how this is meant to work?
Thanks,

11
Feng Office 2 / DB Error when upgrading from 2.01 to 2.1
« on: July 15, 2012, 04:19:08 am »
During the upgrade form 1.7.5 to 2.1 I have followed the migration page (could not post a link)
However, when upgrading from 2.0.1 to 2.1 I (we) get the following error:

Failed to execute DB schema transformations. MySQL said: Duplicate column name 'archived_by_id'
Error upgrading to version 2.1

This has also been recorded under "Installation"  but I am duplicating as it is a FengOffice 2 issue. (I was unable to post the link)

This effectively is preventing me (us) from updating from 1.7.5 to 2.1

Can somebody please help?
Thanks,
Steve H.

12
Installation problems / Re: Upgrade from 201 to 21rc2 DB failure
« on: July 14, 2012, 10:08:41 am »
I am having the same problem.
I have upgraded from 1.7.4  to 1.7.4 then proceeded with the instructions for upgrading 1.x to 2.x.
After upgrading to 2.0.1 I tested the login and the GUI says I am still using version 1.7.5.  This is despite the "installed_version.php" file in the config folder saying the version is 2.0.1.

I have done Ctrl - F5 to reset cache and still seems to be the same

When I ran the public/upgrade page to go from 2.0.1 to 2.1 then it gives this duplicate record error.

So, is there a solution to this problem of  upgrading to 2.1 ?
Thanks,

13
G'day there,
I have just become aware that the "Backup Plugin" is no longer working on my site.
I think it started to fail at about the same time I added the VIEWs etc required to make the Gantt chart extension work.

Has anyone else experienced this?
I cannot investigate now but will do later an update then.
Thanks,
---
Steve

14
Security / How do I prevent direct access to my added Tab index.php?
« on: April 26, 2011, 07:23:39 pm »
I have added a couple of Tabs to my FengOffice thanks to the contributions of information by people here.
One is the Gantt Chart http://forums.fengoffice.com/index.php?topic=3826.0 contribution courtesy of Allen Look.

However, pointing a browser at my Gantt Index Page will open the page without authenticating with FengOffice.

How can I insert PHP code to prevent this?
Currently I have had to resort to .htaccess security (Basic Auth) but this requires FengOffice users to go through this as well.

Can anyone please point me at something similar in the code that would suggest how I can restrict access?
Thanks for the help,
---
Steve

15
Another small issue I had was to do with Resources.
We have users with "display_name" that is different form their "username".
The original list of resources was using "display_name" while the constructed views in mySQL were showing "username".

I was not sure about changing the SQL so I changed:
Code: [Select]
$query_RsFeng = "SELECT display_name as pRes FROM og_users ORDER BY pRes";
To
Code: [Select]
$query_RsFeng = "SELECT username as pRes FROM og_users ORDER BY pRes";

This means that the names shown on the gantt chart correspond with the Resouces selected in the form.
---
Steve

Pages: [1] 2
anything