Feng Forum

Support => Feng Office 1 => Older versions => 1.3-beta => Topic started by: soomon on February 28, 2009, 05:43:46 pm

Title: task view crashed
Post by: soomon on February 28, 2009, 05:43:46 pm
hey there,

i went to taks and set it to view completed tasks.
now i get an errormessage:

$error is not a valid Error instance!exception 'Exception' with message 'Task filter criteria "" not recognised' in .../opengoo/application/controllers/TaskController.class.php:428 Stack trace: #0.../opengoo/environment/classes/controller/Controller.class.php(69): TaskController->new_list_tasks() #1...opengoo/environment/classes/controller/PageController.class.php(62): Controller->execute('new_list_tasks') #2.../opengoo/environment/classes/Env.class.php(133): PageController->execute('new_list_tasks') #3.../opengoo/init.php(151): Env::executeAction('task', 'new_list_tasks') #4 .../opengoo/index.php(9): require('/var/www/virtua...') #5 {main}

the "..." contains the full path to my opengoo installation, but i think that's not important here :))

i can't see any taks any more. i always get that message, even when i log out and log in again...
how to fix that? :/

thx & greets,

soomon
Title: Re: task view crashed
Post by: ignacio on March 03, 2009, 01:35:50 pm
The tasks controller is receiving an invalid filter (an empty string). What are you filtering by? Even the "No filter" option should have a value of "no_filter".

I can start helping you by fixing how the error message is displayed, but I don't know the cause of this problem. To fix it change "throw new Exception" for "flash_error" on line 428 of 'application/controllers/TaskController.class.php'
Title: Re: task view crashed
Post by: soomon on March 03, 2009, 02:08:49 pm
thanks man that helped!

error: Task filter criteria "" not recognised
well, i though i only changed status to "complete"
maybe i also deleted the search criteria accidently..

thanks :)
Title: Re: task view crashed
Post by: skurfuerst on March 03, 2009, 03:37:15 pm
Hi,

I have had the same error after a clean installation and adding a single task. Somehow, it has set the filter to "empty". Commenting out the "throw" fixes the issue.

Greets,
Sebastian
Title: Re: task view crashed
Post by: robrob on April 08, 2009, 08:56:44 pm
Similar error here - similar fix (different file though):

- Cause: in the task panel, I did this:
--- Filter > Milestone > ---none--- > Status Pending

- Error msg: SQL syntax error in environment/library/database/adapters/AbstractDBAdapter.class.php on line 386

- Solved it by commenting that line out. The result (with the filter still in place as noted above): no milestones/tasks showing (blank panel content) instead of error msg

To confirm that this was the exact cause, I reversed the change to the code and repeated my steps. Same error again.

It seems as if the SQL query for that filter is corrupt, since the error is a result of $query_result being false in the prepareAndExecute function.

I hope this helps.