Server Requirements

Before installing Feng Office, make sure that your server matches the following requirements:

Minimum Requirements (Starting with Feng Office 3.7 and older

  1. At least 2 GB of RAM memory. A minimum of 8GB recommended.
  2. At least a dual core 2 duo CPU
  3. At least 200MB of Disk space. A minimum of 1GB recommended.

Minimum Requirements (For Feng Office 3.6.x and older)

  1. At least 2 GB of RAM memory
  2. At least a dual core 2 duo CPU
  3. Disk space will depend on the amount of data you are expecting to manage
Suggested Requirements
  1. At least 6 GB of RAM memory
  2. At least a quad core CPU
  3. Disk space will depend on the amount of data you are expecting to manage, but a minimum of 1GB is advised.

Note: Feng Office could run under a slower server, but we do not suggest it.

Operating System: You can use any Operating System or browser to access the system at user level. You just need an internet connection!

However, when installing it, even though Feng Office can be set up pretty much anywhere, we strongly suggest to install it in the latest stable Debian 64 bits version.

It could be CentOS as well or other Linux distributions, but Debian has shown better results so far.

If you would like to install Feng Office under a Windows or Mac OS server, you can, but please note it would be prone to work slower due to the way they handle requests and that you will miss several features as they do not have as many libraries as Linux has.

For 3.7.0 or newer

Once your Operating System is setup, you will have to install the following:

  • PHP 7.1 or higher
  • Compatible MariaDB or MySQL server and client
  • Apache 2.4 server
  • The following modules and libraries are also required:
  1. php7.0-mysql
  2. php7.0-gd
  3. sendmail (or a similar library for the notifications if you do not send them through an SMTP account)
  4. php7.0-imap (required for IMAP compatibility)
  5. php7.0-curl (required for the API compatibility)
  6. zip
  7. php-xmlrpc (required for document parsing)
  8. catdoc (required for document parsing)
  9. xpdf (required for document parsing)
  10. ghostscript (required for exporting gantt)
  11. imagemagick (required for exporting gantt)
  12. wkhtmltopdf source: http://wkhtmltopdf.org (required for exporting gantt)

For 3.6.x and older

Once you know which Operating System to use, you will have to install the following:

  • PHP 5.6 or higher (except PHP 7, which hasn't been tested yet)
  • MySQL 5.X server and client
  • Apache 2.X server
  • The following modules and libraries are also required:
  1. php5-mysql (compulsory)
  2. php5-gd (compulsory)
  3. sendmail (or a similar one for the notifications if you do not send them through an SMTP account)
  4. php5-imap (required for IMAP compatibility)
  5. php5-curl (required for the API compatibility)
  6. php5-xmlrpc (required for document parsing)
  7. catdoc (required for document parsing)
  8. xpdf (required for document parsing)
  9. ghostscript (required for exporting gantt)
  10. imagemagick (required for exporting gantt)
  11. wkhtmltopdf source: http://wkhtmltopdf.org (required for exporting gantt)

After validating all software requirements, please take a look at this article on how to Setup your server for a Feng Office installation.